Microsoft Excel Basic
ITS: Strategic Support

Reference: ITS1278

Version: 1.00

Date: February 2016

www.up.ac.za
ITS Service Catalogue

- URL to access ITS Service Catalogue: [https://upnet.up.ac.za/SRC/secure/main.jsp](https://upnet.up.ac.za/SRC/secure/main.jsp)
- Enter your Novell ID in the Login box.
- Enter your Novell Password in the Password box.
- Click on the Login button.

**eduroam (education roaming)**

ITS is pleased to announce that eduroam is operational on the UP Wireless network. eduroam enables UP researchers, lecturers, staff and students to access the Internet in a secure manner, on any UP campus, or from the campuses of participating institutions worldwide. Access is granted via a user’s user ID and password (portal credentials). Visiting representatives from other international institutions will similarly be able to access the Internet through the UP Wireless network using their home institution’s credentials. It works on most of the platforms including Windows, Linux, MAC OS, IOS and Android and it is free, with high levels of security.

Basic setup instructions:

- Activate the Wi-Fi on your device
- Browse the available wireless networks
- Select eduroam
- Enter your Username and Password as used at your home institution
- The format for UP staff and students: u01234567@up.ac.za or u87654321@up.ac.za & Portal password
- Click Connect

UP staff can register a request for assistance in the ITS Service Catalogue (follow the QuickLink on the UP Staff Intranet) or contact the IT Helpdesk (012 - 420 3051) for assistance.

The following video-clip provides an easy explanation about eduroam: [https://www.youtube.com/watch?feature=player_embedded&v=TVCmcMZS3uA](https://www.youtube.com/watch?feature=player_embedded&v=TVCmcMZS3uA)

More information about eduroam is available on the following website: [https://www.eduroam.org/](https://www.eduroam.org/)
Title and Synopsis

Title
Microsoft Excel 2016 Basic

Reference
ITS1278

Version
1.00

Date
February 2016

Synopsis
This document is used as a tutorial for the Microsoft Excel 2016 Basic course.

Author(s)
EC Nagel

Copyright
© University of Pretoria 2016. All rights reserved. Information in this document is subject to change. No part of this document may be reproduced, or transmitted, in any form, or by any means, electronic or mechanical, for any purpose, without the express written permission of the University of Pretoria.

Document Control Details

Approval sheet
None

Master Document
Training Office

Electronic document
None
# TABLE OF CONTENTS

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>ITS SERVICE CATALOGUE</strong></td>
<td>2</td>
</tr>
<tr>
<td><strong>EDUROAM (EDUCATION ROAMING)</strong></td>
<td>2</td>
</tr>
<tr>
<td><strong>COURSE OVERVIEW</strong></td>
<td>10</td>
</tr>
<tr>
<td>PREREQUISITES</td>
<td>10</td>
</tr>
<tr>
<td><strong>COURSE OBJECTIVES</strong></td>
<td>10</td>
</tr>
<tr>
<td><strong>MICROSOFT EXCEL 2016</strong></td>
<td>12</td>
</tr>
<tr>
<td>WHAT IS NEW IN MICROSOFT EXCEL 2016</td>
<td>13</td>
</tr>
<tr>
<td>ACTIVATE MICROSOFT EXCEL 2016</td>
<td>15</td>
</tr>
<tr>
<td>QUICK ACCESS TOOLBAR</td>
<td>16</td>
</tr>
<tr>
<td><strong>THE RIBBON</strong></td>
<td>16</td>
</tr>
<tr>
<td>Ribbon Display Options</td>
<td>17</td>
</tr>
<tr>
<td>Tabs</td>
<td>18</td>
</tr>
<tr>
<td>Contextual Tabs</td>
<td>18</td>
</tr>
<tr>
<td>Groups</td>
<td>18</td>
</tr>
<tr>
<td>The Dialog Box Launcher</td>
<td>19</td>
</tr>
<tr>
<td><strong>Tell Me</strong></td>
<td>19</td>
</tr>
<tr>
<td>Backstage View</td>
<td>19</td>
</tr>
<tr>
<td><strong>THE FORMULA BAR</strong></td>
<td>19</td>
</tr>
<tr>
<td><strong>SPREADSHEET TERMINOLOGY</strong></td>
<td>20</td>
</tr>
<tr>
<td>ROWS AND COLUMNS</td>
<td>20</td>
</tr>
<tr>
<td>CELL AND CELL ADDRESSES</td>
<td>20</td>
</tr>
<tr>
<td><strong>DISPLAY OPTIONS</strong></td>
<td>20</td>
</tr>
<tr>
<td>NAVIGATE WITHIN A WORKSHEET</td>
<td>23</td>
</tr>
<tr>
<td>Using the Mouse</td>
<td>23</td>
</tr>
<tr>
<td>Keyboard Shortcuts</td>
<td>23</td>
</tr>
<tr>
<td>Scroll Bars</td>
<td>24</td>
</tr>
<tr>
<td>Switch between sheets in a Workbook</td>
<td>24</td>
</tr>
<tr>
<td><strong>RANGES IN MICROSOFT EXCEL 2016</strong></td>
<td>25</td>
</tr>
<tr>
<td>Select using the Mouse</td>
<td>25</td>
</tr>
<tr>
<td>Select using the Keyboard</td>
<td>26</td>
</tr>
<tr>
<td><strong>WORKBOOKS AND WORKSHEETS</strong></td>
<td>28</td>
</tr>
<tr>
<td>CREATE A NEW WORKBOOK</td>
<td>28</td>
</tr>
<tr>
<td>ENTER NUMBERS OR TEXT</td>
<td>29</td>
</tr>
<tr>
<td><strong>DATA TYPE</strong></td>
<td>29</td>
</tr>
<tr>
<td><strong>EDIT, CLEAR AND REPLACE CELL CONTENTS</strong></td>
<td>30</td>
</tr>
<tr>
<td><strong>Undo and Redo commands</strong></td>
<td>31</td>
</tr>
<tr>
<td><strong>CHANGE WHICH CELL IS SELECTED NEXT</strong></td>
<td>31</td>
</tr>
<tr>
<td>ENTER DATA IN RANGE OF CELLS</td>
<td>31</td>
</tr>
<tr>
<td>Fill a range of cells with the same data</td>
<td>31</td>
</tr>
</tbody>
</table>
**EXERCISE 3: COLUMNS AND ROWS**

- **ADJUST COLUMN WIDTH** .......................................................... 53
- **ADJUST ROW HEIGHT** ............................................................... 55
- **FORMATTING CELLS** ............................................................... 55
- **Apply cell styles** ................................................................. 55
- **FORMAT BORDERS** ................................................................. 55
- **Change Borders** ................................................................. 56
INTRODUCTION .................................................................................................................. 104

CHARTING RULES .............................................................................................................. 104
CHART ELEMENTS ............................................................................................................ 106
GUIDELINES FOR CHARTING .......................................................................................... 107
Chart Summary .................................................................................................................. 107
General Hints ..................................................................................................................... 109
Worksheet Design .............................................................................................................. 111
Create a Basic Chart ........................................................................................................... 112
Modify a Chart .................................................................................................................... 113

DATA SERIES AND DATA RANGES .................................................................................... 114
Deleting Data Series .......................................................................................................... 115

FORMAT A CHART .............................................................................................................. 115
The Format Dialog ............................................................................................................ 116
Apply Chart Layout ........................................................................................................... 117
Applying Chart Styles ...................................................................................................... 117

FILL AREAS WITH COLOURS, PATTERNS, AND PICTURES ........................................... 117
Add Borders and Formatting Lines .................................................................................... 118
Create an Exploding Pie or Doughnut Slice ....................................................................... 119
SPARKLINES ..................................................................................................................... 119
Customize Sparklines ....................................................................................................... 120

EXERCISE 12: CHARTS ........................................................................................................ 121

PREVIEW AND PRINT WORKSHEETS ........................................................................... 123

BACKSTAGE VIEW ............................................................................................................ 123
PRINTING TIPS .................................................................................................................. 124
DEFAULT PRINTER ............................................................................................................. 124
PRINT ACTIVE WORKSHEETS .......................................................................................... 124

DEFINE PRINT AREA ........................................................................................................ 126
Defining the Print Area: Dialog Option ............................................................................. 126
Defining the Print Area: Print Area Option ....................................................................... 126
Print Options ..................................................................................................................... 127
ADDITIONAL PRINT OPTIONS ........................................................................................ 127

PAGE SETUP DIALOG ........................................................................................................ 128
Page Setup Dialog Tabs: Page ............................................................................................ 129
Page Setup Dialog Tabs: Margins ....................................................................................... 130
Page Setup Dialog Tabs: Header/Footer ............................................................................. 130
Page Setup Dialog Tabs: Sheet .......................................................................................... 131
CUSTOMIZE PAGE LAYOUT ............................................................................................. 132
Change the Orientation ..................................................................................................... 132
Change the Paper Size ...................................................................................................... 133
Adjust the Scale ................................................................................................................. 134
Adjust the Margins ............................................................................................................. 134
Adjust the Header and Footer Margins .............................................................................. 134
Centre the Worksheet on the Page ................................................................. 135
MODIFY HEADERS AND FOOTERS ............................................................... 135
Set a Custom Page Number ........................................................................ 135
ADD HEADERS AND FOOTERS ................................................................. 136
Use Pre-set Headers and Footers .............................................................. 136
Create Custom Headers and Footers ....................................................... 137
Add a Custom Header or Footer: Dialog Box Option .................................. 138
Header and Footer Elements .................................................................... 138
OTHER PRINTING OPTIONS ........................................................................ 140
Print Gridlines ............................................................................................ 140
Print Row and Column Headings ............................................................. 140
Repeat Items on Each Page ...................................................................... 140
Change the Print Quality .......................................................................... 141
EXERCISE 13: PRINTING ........................................................................... 141
MICROSOFT EXCEL 2016 TIPS AND TRICKS ........................................ 142
QUICK REFERENCE GUIDE ....................................................................... 143
GLOSSARY OF TERMS .............................................................................. 146
Course Overview

In this course you will learn to use Microsoft Excel 2016 as a powerful spreadsheet software program that allows you to make quick and accurate numerical calculations.

Prerequisites

- Microsoft Windows

Course Objectives

After completing this course, you should be able to:

- Understand the Microsoft Excel 2016 fundamentals
- Edit a worksheet
- Format a worksheet
- Manage your workbooks
- Work with lists
- Create and work with charts
- Understand the printing options
Microsoft Excel 2016
Basic

Fundamentals

Objectives

After completion of this lesson, you will be able to –

- Activate Microsoft Excel 2016
- Know what is new in Microsoft Excel 2016
- Understand the new Excel Screen
- Understand the Microsoft Excel Ribbon and Formula Bar
Microsoft Excel 2016

Microsoft Excel 2016 is a spreadsheet and data analysis program which combines power and flexibility with ease of use. A spreadsheet contains a table of values which can be calculated by using formulas and functions.

The basic document file in Microsoft Excel is a workbook. Each workbook consists of three default worksheets, which are identified by tabs displayed along the bottom of the screen. Each Excel worksheet consists of 16,384 columns and 1,048,576 rows. Your view is limited but the remaining cells (over 16.7 million) are there if you require them. By default the first worksheet is called Sheet1 and the next is called Sheet2.

Data is entered into a worksheet. The worksheet consists of rows and columns and is essentially a very large table. Cells are the basic building blocks of Microsoft Excel. Each cell has a cell address, which is determined, by the column and row position. The intersection of a row and column forms a cell, the smallest working section of a worksheet. Cells contain values, labels, or formulas, and are identified by unique addresses, such as A1, B6, or D23.

![Figure 1-1: Rows, Columns, Cells, and Ranges.](image-url)
Values are numbers you want to use in your calculations. Labels are the text headings or titles that describe what the numbers represent. Formulas perform calculations, manipulating the values in some way to produce a result.

Cells and a cell address is very important in Microsoft Excel. You can use information from a cell, or move to a particular cell from wherever you are, by referring to its cell address. A cell must be active before you can enter a value, label, or formulae into it. A highlighted box called the cell selector indicates the active cell. Whenever you open a workbook, the upper-left cell of the first worksheet A1, is the active cell.

By default, Microsoft Excel will save the spreadsheet file with the .xlsx extension. The spreadsheet file contains the workbook and the worksheets within the workbook.

What is New in Microsoft Excel 2016

- The new **Quick Analysis** tool allows you to convert your data into a chart or table in two steps or less. Preview your data with conditional formatting, Sparklines, or charts, and make your choice stick in just one click.

- **Funnel Charts** show values across multiple stages in a process. Typically, the values decrease gradually, allowing the bars to resemble a funnel.

- **Improved AutoComplete.** The Microsoft Excel autocomplete is not as picky as it was before. If you want to use the `NETWORKDAYS` function, but you cannot remember how it is spelled. If you just type `=DAYS`, the autocomplete menu will bring back all of the functions that contain DAYS, including, `NETWORKDAYS`. Before, you had to spell the function name exactly.

- **Six new Chart types.** Visualizations are critical to effective data analysis as well as compelling storytelling. In Excel 2016 six new charts with the same rich formatting options that you are familiar with have been added to help you create some of the most commonly used data visualizations of financial or hierarchal information or for revealing statistical properties in your data.

- **Get and Transform Query.** Before analysis can begin, you must be able to bring in the data relevant to the business question you are trying to answer. Excel 2016 now comes with built-in functionality that brings ease and speed to getting and transforming data - allowing you to find and bring all the data you need into one place.

- **One click forecasting.** In previous versions of Microsoft Excel, only linear forecasting had been available. In Excel 2016, the `FORECAST` function has been extended to allow forecasting based on Exponential Smoothing (such as,
FORECAST.ETS() …). This functionality is also available as a new one-click forecasting button.

- **3D Maps.** The popular 3D geospatial visualization tool, Power Map, has been renamed and is now available to all Excel 2016 customers and is built into Excel. This innovative set of storytelling capabilities has been renamed 3D Maps and can be found along with other visualization tools by clicking 3D Map on the Insert tab.

- **Financial Templates.** New My Cash flow template, and the Stock Analysis template. These templates track what you earn, how much you spend, and where your spending occurs. Plus, quickly analyse and compare the performance of selected stocks over time.

- **Calendar Insights Template.** View your calendar as a dashboard and drill into the data.

- **PivotTable Enhancements.** Automatic relationship detection. Create, edit and delete custom measures. Automatic time grouping. PivotChart drill down buttons. Search in the PivotTable. Smart rename. Usability improvements.

- **Multi-select slicer.** You can select multiple items in an Excel slicer on a touch device. This is a change from prior versions of Excel where only one item in a slicer could be selected at a time using touch input. You can enter Slicer multi-select mode by using the new button located in the Slicer’s label.

- **Publish and share your analysis with power BI.** A report is not complete without being able to share it with the right people. Once you are finished preparing your data analysis, you can share it with your workgroup or clients through Power BI with just one button. Once published to Power BI, use your data models to quickly construct interactive reports and dashboards.

- **Quick shape formatting.** This feature increases the number of default shape styles by introducing new preset styles in Microsoft Excel.

- **Insert pictures with the correction orientation.** With automatic image rotation, once you insert an image into Excel, it automatically rotates the picture to match the camera’s orientation. You can manually rotate the image to any position after insertion. This only affects newly inserted images and does not apply to pictures in existing documents.

- **Do things quickly with Tell Me.** There is a new text box on the ribbon in Excel 2016 that says Tell me what you want to do. This is a text field where you can enter words and phrases related to what you want to do next and quickly get to features you want to use or actions you want to perform. You can also choose to get help related to what you are looking for, or perform a Smart Lookup on the term you entered.
• **Ink Equations.** Including math equations has gotten much easier. You can go to Insert ⇒ Equation ⇒ Ink Equation, anytime you want to include a complex math equation in your workbook. If you have a touch device, you can use your finger or a touch stylus to write math equations by hand, and Excel will convert it to text.

• **Improved version history.** You can go to File ⇒ History to see a complete list of changes that have been made to your workbook and access earlier versions.

---

**Activate Microsoft Excel 2016**

When you open Excel 2016 for the first time, the Excel Start Screen will appear. From here, you will be able to create a new workbook, choose a template, and access your recently edited workbooks.

There are several ways to activate Microsoft Office Excel 2016.

- Click on the **Windows Start** button. Select **All Programs** ⇒ **Microsoft Office 2016** ⇒ **Excel 2016**.
- The following screen will appear:

  ![Excel Start Screen](image)

  - From the list of available templates click on **Blank workbook** to open a new blank workbook in Microsoft Excel.
  - The following screen will appear:
Quick Access Toolbar

The Quick Access Toolbar allows you to access common commands no matter which tab is selected. You can customize the commands depending on your preference.

The Ribbon

The Ribbon contains all of the commands you will need to perform common tasks in Excel. It has multiple tabs, each with several groups of commands. In Excel 2016 you can create your own tabs and groups and rename or change the order of the built-in tabs and groups. There are three basic components to the Ribbon:

- **Tabs** - There are eight tabs on the Ribbon, each representing a core task in Microsoft Excel.
- **Groups** - Each tab has groups with commands associated with that tab.
- **Commands** - A command is a button, a box to enter information, or a menu.
You can adjust how the Ribbon is displayed with the Ribbon Display Options. Certain programs, such as Adobe Acrobat Reader, may install additional tabs to the Ribbon. These tabs are called add-ins.

**Ribbon Display Options**

The Ribbon is designed to respond to your current task, but you can choose to minimize it if you find that it takes up too much screen space. Click the Ribbon Display Options arrow in the upper-right corner of the Ribbon to display the drop-down menu.

There are three modes in the **Ribbon Display Options** menu:

- **Auto-hide Ribbon**: Auto-hide displays your workbook in full-screen mode and completely hides the Ribbon. To show the Ribbon, click the **Expand Ribbon** command at the top of screen.

- **Show Tabs**: This option hides all command groups when they are not in use, but tabs will remain visible. To show the Ribbon, simply click a tab.
• **Show Tabs and Commands**: This option maximizes the Ribbon. All of the tabs and commands will be visible. This option is selected by default when you open Excel for the first time.

---

**Tabs**

Tabs are equivalent to the menus in the old Excel Menu Bar. When you choose a tab you can see **groups** of commands associated with that tab. Each tab relates to a type of activity, such as writing or laying out a page. To reduce clutter, some tabs are shown only when needed. The Picture Tools tab is shown only when a picture is selected.

The main commands in Microsoft Excel are gathered on the first tab, the **Home** tab. The commands on this tab are those that Microsoft has identified as the most commonly used when people do basic tasks with worksheets.

---

**Contextual Tabs**

When you select certain objects, Microsoft Excel displays **Contextual Tabs**, with commands to help you work with the object.

---

**Groups**

Commands are organized in logical **groups**, which are collected together under **tabs**. These are the sections within each tab that contain related commands. Here, for example, are the first two groups on the **Home** tab.
Some group labels can be misleading. The Font group includes the Fill Colour tool that is used to change the colour of worksheet cells and it also includes the Border tool.

The Dialog Box Launcher

This is the arrow icon in the lower-right corner of some groups, which launches the dialog associated with that group. This arrow indicates that there are more options available for the group. Click the arrow, to open a dialog box or a task pane.

- Click the arrow at the bottom of a group to get more options.
- Click the arrow in the Font group. The Format Cells dialog opens.

Tell Me

The Tell me box works like a search bar to help you quickly find tools or commands you want to use.

Backstage View

Click on the File tab to get access to the Backstage view to open, save, print, share, and manage your files and set your program options. The Backstage view is where you manage your files and the data about them e.g. creating, saving, inspecting for hidden metadata or personal information, and setting options.

The Formula Bar

The Formula bar is a bar at the top of the Microsoft Excel window that you use to enter or edit values or formulas in cells or charts. It displays the constant value or formula stored in the active cell.

To accommodate long names, you can also resize the name box at left end of the formula bar that identifies the selected cell, chart item, or drawing object. To name a cell or range, type the name in the Name box and press the Enter key.
INFORMATION TECHNOLOGY SERVICES

Click | Button | Function
--- | --- | ---
Name Box | | The Name box displays the location, or name, of a selected cell. Next to the reference area, the formula bar accepts entries for the worksheet. In the formula bar, you can enter or edit data, a formula, or a function that will appear in a specific cell.

Spreadsheet Terminology

<table>
<thead>
<tr>
<th>Terminology</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Workbook Name</td>
<td>This name is located in the title bar.</td>
</tr>
<tr>
<td>Row headings</td>
<td>Rows refer to the horizontal rows and the row numbers are placed on the left-hand side.</td>
</tr>
<tr>
<td>Column headings</td>
<td>Columns refer to the vertical rows and the column numbers appear on the top.</td>
</tr>
<tr>
<td>Cell</td>
<td>The intersection between a row and a column.</td>
</tr>
<tr>
<td>Active cell</td>
<td>The cell where information is entered.</td>
</tr>
<tr>
<td>Status Bar</td>
<td>Provides information about the position of the cursor.</td>
</tr>
<tr>
<td>Sheet tabs</td>
<td>Indicate the active sheet in the workbook.</td>
</tr>
<tr>
<td>Scroll bars</td>
<td>Contains arrowheads for moving through a worksheet.</td>
</tr>
</tbody>
</table>

Rows and Columns

- A worksheet document is divided into rows and columns.
- The rows are numbered from 1 to 1,048,576.
- The 16,384 columns are numbered from A to Z and continuing from AA to XFD, ending at IV.

Cell and Cell Addresses

Each cell has its own address by column and row intersection, e.g. C10.

Display Options

In earlier versions of Microsoft Office, you could set your preferences for specific view, display, and editing settings in the Tools ⇒ Options dialog. As part of the new
user interface in the Microsoft Office 2016 programs, the **Options** command on the **Tools** menu has been moved to under **Options** when you click the **File** tab.

- The **Excel Options** dialog appears on the screen:

  ![Excel Options Dialog](image)

- In the left hand frame of the **Excel Options** dialog, click on **Advanced**.
- The advanced options for working with Microsoft Excel are displayed.
- Under the heading **Display**, select the applicable options.
Under the heading **Display options for this Workbook** and **Display options for this Worksheet**, select the applicable options.

### Display options for the Workbook

<table>
<thead>
<tr>
<th>Select</th>
<th>To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show horizontal scroll bar</td>
<td>Displays the horizontal scroll bar.</td>
</tr>
<tr>
<td>Show vertical scroll bar</td>
<td>Displays the vertical scroll bar.</td>
</tr>
<tr>
<td>Show sheet tabs</td>
<td>Displays sheet tabs so that you can move among and select workbook sheets. Sheet tabs appear at the bottom of the sheet window. By default, all dates in the range of cells or table column are grouped by a hierarchy of years, months, and days. Selecting or clearing a higher level in the hierarchy selects or clears all nested dates below that level.</td>
</tr>
<tr>
<td>Group dates in the AutoFilter menu</td>
<td>Select All to show all objects. Select Nothing to hide all objects.</td>
</tr>
</tbody>
</table>

For objects, show
Display options for the Worksheet

<table>
<thead>
<tr>
<th>Select</th>
<th>To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show row and column headers</td>
<td>Displays row and column headers</td>
</tr>
<tr>
<td>Show formulas in cells instead of their calculated results</td>
<td>Displays the formulas in cells instead of the results.</td>
</tr>
<tr>
<td>Show sheet right-to-left</td>
<td>Displays sheets from right-to-left</td>
</tr>
<tr>
<td>Show page breaks</td>
<td>Displays the page breaks on the screen</td>
</tr>
<tr>
<td>Show a zero in cells that have zero values</td>
<td>Displays a 0 (zero) in cells that contain zero values.</td>
</tr>
<tr>
<td>Show outline symbols</td>
<td>Displays an outline symbol</td>
</tr>
<tr>
<td>Show gridlines</td>
<td>Displays cell gridlines</td>
</tr>
<tr>
<td>Gridline Colour</td>
<td>Sets the colour for gridlines</td>
</tr>
</tbody>
</table>

Navigate within a Worksheet

In Microsoft Excel, files are called workbooks. Workbooks can contain multiple worksheets, as well as chart sheets. Before entering data into a worksheet, it is important to know how to move around on the worksheet.

Using the Mouse

- You must first make a cell active before you can enter information in the cell. Click in a cell with the white cross pointer. A heavy border surrounds the active cell. The cell reference for the active cell appears in the Name box, on the left side of the Formula bar, and the corresponding row and column headers become bold and raised.
- To move to a particular cell in a quick way, enter the cell that you wish to jump to into the Name Box (at the top, left of the screen).
- Press the Enter key and the cursor will move to the cell entered.
- Scroll bars appear on the right and bottom side of the worksheet, and are used to view different parts of a worksheet quickly when it contains more information than can be displayed on one screen.

Keyboard Shortcuts

<table>
<thead>
<tr>
<th>Click on</th>
<th>To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Arrow keys</td>
<td>Move one cell up, down, left, or right in a worksheet</td>
</tr>
</tbody>
</table>
## Click on

<table>
<thead>
<tr>
<th>Click on</th>
<th>To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Home</td>
<td>Move to the first cell in the row</td>
</tr>
<tr>
<td>End</td>
<td>Move to the end of a row</td>
</tr>
<tr>
<td>Ctrl + Home</td>
<td>Move to the first cell in the worksheet - A1</td>
</tr>
<tr>
<td>Ctrl + End</td>
<td>The last cell with data in a worksheet</td>
</tr>
<tr>
<td>Page Down</td>
<td>One screen down</td>
</tr>
<tr>
<td>Page Up</td>
<td>One screen up</td>
</tr>
<tr>
<td>Ctrl + →</td>
<td>Move to last column</td>
</tr>
<tr>
<td>Ctrl + ↓</td>
<td>Move to the last row 1048576</td>
</tr>
<tr>
<td>Ctrl + G or F5</td>
<td>Open the Go To dialog box where you can type in the cell address to which you want to move</td>
</tr>
</tbody>
</table>

### Scroll Bars

The Scroll Bars are used to see different areas of a worksheet.

- Move the mouse pointer over the vertical scroll box (the box that moves within the vertical scroll bar), press and hold down the mouse button.
- Press **Ctrl + Home** to return to cell **A1**, the first cell of the worksheet.

### Switch between sheets in a Workbook

Each worksheet has a tab that appears near the bottom of the workbook window. To switch to a different sheet, click the sheet tab at the bottom of the screen. When there are too many tabs in a workbook to display them all, scroll through the worksheet tabs by clicking the scroll tab buttons, located at the bottom of the screen near the worksheet tabs.

- Click the sheet tab at the bottom of the screen.
- Right-click the sheet tab scroll buttons and select the worksheet from the shortcut menu.
- To scroll through worksheets in a workbook, click the corresponding scroll sheet tabs at the bottom of the screen.

The following table describes the sheet tab scroll tabs.
### Button Description

- ![◀](image) Scrolls to the previous sheet tab into view
- ![▶](image) Scrolls to the next sheet tab into view

- Press **Ctrl + PgUp** to move to the previous sheet in the workbook.
- Press **Ctrl + PgDn** to move to the next sheet in the workbook.

### Ranges in Microsoft Excel 2016

Since it would be impractical to work with one cell at a time, select a group of cells or a range, to make changes to the font or to delete the contents of cells. It is easier to apply formats or other commands to selected cells (called a range) than to change each cell individually. The selected cells are highlighted.

#### Select using the Mouse

<table>
<thead>
<tr>
<th>Select</th>
<th>With a</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>A cell</strong></td>
<td>■ Click on the cell you wish to select.</td>
</tr>
<tr>
<td><strong>Range of cells</strong></td>
<td>■ Click on the first cell in the range.</td>
</tr>
<tr>
<td></td>
<td>■ Hold down the left mouse button and drag over the cells you wish to include in the selection.</td>
</tr>
<tr>
<td><strong>Range of cells making up a rectangular block</strong></td>
<td>■ Click on the first cell of the rectangular block that you wish to select.</td>
</tr>
<tr>
<td></td>
<td>■ Move down to the cell that marks the bottom right corner of the rectangular block.</td>
</tr>
<tr>
<td></td>
<td>■ Press and hold down the <strong>Shift</strong> key.</td>
</tr>
<tr>
<td></td>
<td>■ Click once on the last cell of the required block.</td>
</tr>
<tr>
<td></td>
<td>■ Release the <strong>Shift</strong> key.</td>
</tr>
<tr>
<td></td>
<td>■ You can also select the first cell in the range, and then press <strong>F8</strong> to extend the selection by using the arrow keys. To stop extending the selection, press <strong>F8</strong> again.</td>
</tr>
<tr>
<td><strong>Only the typed area of a worksheet</strong></td>
<td>■ Click on the first (or last) cell, hold down the <strong>Shift</strong> button and click on the last (or first) cell.</td>
</tr>
<tr>
<td><strong>Non-adjacent range</strong></td>
<td>■ Select the first range.</td>
</tr>
<tr>
<td></td>
<td>■ Select the next range but hold down the <strong>Ctrl</strong> key while you click and drag with the mouse.</td>
</tr>
<tr>
<td>Select</td>
<td>With a</td>
</tr>
<tr>
<td>----------------------</td>
<td>----------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Select a row</strong></td>
<td>■ Click on the row heading number.</td>
</tr>
<tr>
<td><strong>Select a column</strong></td>
<td>■ Click on the column heading letter.</td>
</tr>
<tr>
<td><strong>The entire worksheet</strong></td>
<td>■ Click the button in the top left corner where the row and column headings intersect.</td>
</tr>
<tr>
<td></td>
<td>■ Press <strong>Ctrl + A</strong>.</td>
</tr>
<tr>
<td><strong>Select several sheets</strong></td>
<td>■ Click on the first sheet tab.</td>
</tr>
<tr>
<td></td>
<td>■ Click on other sheet tabs you wish to select while pressing the <strong>Ctrl</strong> key.</td>
</tr>
<tr>
<td><strong>Select all sheets</strong></td>
<td>■ Click on a sheet tab using the right-hand mouse button to display the pop-up menu.</td>
</tr>
<tr>
<td></td>
<td>■ Choose <strong>Select All Sheets</strong>.</td>
</tr>
<tr>
<td><strong>Deselect</strong></td>
<td>■ Click anywhere outside the selection.</td>
</tr>
</tbody>
</table>

**Select using the Keyboard**

<table>
<thead>
<tr>
<th>Select</th>
<th>With</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>A cell</strong></td>
<td>Use the arrow keys</td>
</tr>
<tr>
<td><strong>Selection of cells</strong></td>
<td>Shift + Arrow keys</td>
</tr>
<tr>
<td><strong>An entire row</strong></td>
<td>Shift + Spacebar</td>
</tr>
<tr>
<td><strong>An entire column</strong></td>
<td><strong>Ctrl</strong> + Spacebar</td>
</tr>
<tr>
<td><strong>Only the typed area of a worksheet</strong></td>
<td>Click on the first (or last) cell and then press the <strong>Ctrl</strong>, <strong>Shift</strong> and <strong>End</strong> keys simultaneously</td>
</tr>
<tr>
<td><strong>The entire worksheet</strong></td>
<td><strong>Ctrl</strong> + <strong>Shift</strong> + <strong>Spacebar</strong></td>
</tr>
</tbody>
</table>
Microsoft Excel 2016 Basic

Enter Text and Numbers

Objectives

After completion of this lesson, you will be able to –

- Create a new workbook
- Open and save a workbook
- Enter text and numbers
- Use the AutoCorrect function
**Workbooks and Worksheets**

Microsoft Excel automatically starts with a new blank workbook containing three worksheets. A worksheet is a very large table, consisting of rows and columns. The rows are identified by numbers and the columns are identified by letters. This is where you enter the data. A worksheet is created using a five-step process:

- Enter the text that describes the values.
- Enter the numbers, or values.
- Add formulas to calculate the results.
- Format the entries to make the spreadsheet easy to read and understand.
- Save and print the workbook.

### Create a new workbook

- Click the **File** tab. The Backstage view will appear.
- Click on the **New** option and then click on **Blank workbook**.
- A new empty workbook with three worksheets will open on the screen.
- Enter numbers, formulas, functions and text into individual cells. A range is made up of cells. Ranges can be any rectangular area of cells within a worksheet.
- Microsoft Excel identifies active cells with a bold outline around the cell and highlighting the **Column** heading letter and the **Row** heading number of the cell.
- There are two basic types of information that can be entered in an Excel cell.
  - **Text** – any type of text or information not used in any calculations.
  - **Numbers** – any type of numerical data (numbers, percentages, fractions, currencies, dates or times) usually used in formula and functions.

When you type text or numbers, it is displayed in the **Formula Bar** and in the **active cell** itself. Two small boxes appear to the right of the **Name** box when you begin an entry. The **X** or **Cancel** box clears the current entry from the cell and restores the previous entry. If you click the check mark **Enter** box, the current information is placed into the cell.

- Press the **Enter**, **Tab**, or **Arrow** keys to confirm an entry.
Enter Numbers or Text

Data can be typed into cells by using the keyboard. Text is used as worksheet headings to make the worksheet easy to read and understand. Press the Enter key to move to the next cell. By default, text is automatically left-aligned.

Numbers, dates, and other numerical information in a worksheet are usually used in calculations. Click in the cell in which you want to enter a number. Type the value and press the Enter key. Microsoft Excel treats information that contains numbers, dates or times and certain numerical punctuation as a value and automatically right-aligns the value in the cell.

Data Type

- The following table gives a description of the different data types that can be entered in a worksheet cell:

<table>
<thead>
<tr>
<th>Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text</td>
<td>Text is any character, or combination of characters and numbers. Microsoft Excel does not interpret the data entry as numeric, date or a formula, but it will be seen as text. By default text is left-aligned. If you enter text that is wider than the cell, it will flow into the adjacent cell if the adjacent cells are empty. If the adjacent cell contains data, the text display is truncated. The full text is still available in the Formula bar.</td>
</tr>
<tr>
<td>Numbers</td>
<td>Numbers are the raw material of a spreadsheet. We also refer to numbers as constants. Numbers are entered directly into the cells and are used in calculations. Numbers can be any type of numerical data - numerals from 0 to 9. Numbers can also use numerical punctuation including the period for a decimal point, the hyphen for negative values, the dollar sign for currencies, the percentage sign for percentages and the comma for separating numbers. If you add a percentage or currency sign to a number Excel will recognise it as a number.</td>
</tr>
<tr>
<td>Type</td>
<td>Description</td>
</tr>
<tr>
<td>------</td>
<td>-------------</td>
</tr>
<tr>
<td></td>
<td>For negative numbers, type a minus sign before the number.</td>
</tr>
<tr>
<td></td>
<td>For decimals, use a period for the decimal point.</td>
</tr>
<tr>
<td></td>
<td>By default, numeric values are right-aligned.</td>
</tr>
<tr>
<td></td>
<td>If a number exceeds the width of a column, ####### signs will be displayed in the cell.</td>
</tr>
<tr>
<td>Formula</td>
<td>Formula consist of values; cell references; arithmetic operations and special functions.</td>
</tr>
<tr>
<td></td>
<td>Formula are always preceded by a = sign.</td>
</tr>
<tr>
<td>Date and Time</td>
<td>Dates and times must be entered in the format accepted by Excel separated either by hyphens or slashes.</td>
</tr>
<tr>
<td></td>
<td>Usually the format is the same as the date format in the Regional Options of Microsoft Windows.</td>
</tr>
<tr>
<td></td>
<td>You can type the date and time in the same cell, by separating them with a space.</td>
</tr>
<tr>
<td></td>
<td>Dates will by default be right-aligned.</td>
</tr>
<tr>
<td></td>
<td>To enter the current date, press Ctrl + : and to enter the current time press Ctrl + Shift + ;.</td>
</tr>
</tbody>
</table>

**Edit, Clear and Replace Cell Contents**

Once data have been entered in a cell and the Enter key pressed, the data cannot be changed directly. There are various methods to edit the contents of a cell.

- To delete data in a cell and leave the cell blank, click the cell and press the Delete or Backspace key.
- When the Delete key is pressed only the text and not all the formats used with the text will be deleted.
- Select the cell to be edited, click in the Formula bar, and edit the cell contents in the Formula bar.
- Double-click the cell you want edit, and edit the cell contents directly in the cell.
- On the Home tab, in the Editing group, click the Clear button to clear the text as well as the formatting.
- If you want to replace the existing data, simply overtype the data in the existing cell.
- If you want to edit the existing data, press the F2 function key or double-click on the data to be edited. The edit mode is activated, and the data can be edited.
**Undo and Redo commands**

- The **Undo** command reverses certain commands or deletes the last entry typed.
- The undo command is available on the **Quick Access Toolbar**.
- Immediately after you undo an action, this command changes to **Redo**, allowing you to restore what you reversed.

**Change which cell is selected next**

When you press the **Enter** key after working in a cell, Microsoft Excel moves the cursor to an adjacent cell or leaves the cursor in the current cell.

- Click the **File** tab, and then click on **Options**.
- The **Excel Options** dialog appears on the screen.
- In the left-hand frame, click **Advanced options ⇒ Editing options** and select the option **After pressing Enter, move selection** and set the direction in which the active cell will move by clicking on the down arrow in the **Direction** section of the dialog.
- Click on the **Ok** button to close the **Options** dialog.

**Enter data in range of cells**

A range consists of two or more selected cells and is identified by the first and last cells in the range. To select a range, position the cursor on the first cell, click and hold the mouse button, drag the cursor to the last cell you want in the range, and then release the mouse button. By selecting a range, you restrict where the cell pointer can move.

- Use the mouse to drag across a range of cells in which you wish to enter numbers.
- This will highlight the selected range.
- Type the first entry and press the **Enter** key.
- The active cell moves down one cell.
- Enter the remaining numbers following each with the **Enter** key.
- When you reach the bottom of each column (in the selected range) the active cell moves to the top of the next column.

**Fill a range of cells with the same data**

- Highlight the cells you wish to fill.
- In the first cell, enter the information that you wish to fill the selected range with.
Press Ctrl + Enter to fill the range with the same data.

**AutoFill**

The Fill command is used to fill data into worksheet cells. You can also have Microsoft Excel automatically continue a series of numbers, number and text combinations, dates, or time periods, based on a pattern. To quickly fill in several types of data series, you can select cells and drag the fill handle.

- Select the cell containing the first entry, then click and drag the AutoFill handle found on the lower-right corner of the cell selector.

![Fill handle](image)

**Fill handle**

- The fill handle is displayed by default with a small black square in the lower-right corner of the selection.
- When you point to the fill handle, the pointer changes to a black cross.
- To copy contents to adjacent cells or to fill a series such as dates, drag the fill handle.
- To display a shortcut menu that contains full options, hold down the right mouse button as you drag the fill handle.

**Series Command**

In Microsoft Excel it is possible to create a custom fill series or sorting order from existing items listed on a worksheet, or to type the list from scratch.

- On the worksheet, select the list of items that you want to use in the fill series.
- Click the File tab, and then click on Options.
- Click the Advanced category, and then under General, click Edit Custom Lists.
- In the Custom lists box, select the list that you want to edit or delete, and then do one of the following:
To edit the fill series, make the changes that you want in the **List entries** box, and then click **Add**.

To delete the fill series, click **Delete**.

Verify that the cell reference of the list of items that you selected is displayed in the **Import list from cells** box, and then click on **Import**.

The items in the list that you selected are added to the **Custom lists** box.

Click on **Ok**.

On the worksheet, click a cell, and then type the item in the custom fill series that you want to use to start the list.

Drag the fill handle across the cells that you want to fill.

To type a new list, select **New List** in the **Custom Lists** box, and type the entries in the **List entries** box, beginning with the first entry.

Press the **Enter** key after each entry.

Complete the list and click on the **Add** button.

Click on the **Close** button to close the **Options** dialog.

**Types of Series**

Several types of series can automatically be filled in by selecting the cells and dragging the fill handles or by using the **Series** command.

On the **Home** tab, in the **Editing** group, click the drop down arrow of the **Fill** button and click on **Series**.
The **Series** dialog will appear:

![Series dialog](image)

To select the type of series from the shortcut menu, select the starting value for the series; then hold down the right mouse button and drag the fill handle.

### Date

A date series can include increments of days, weeks, or months specified, or it can include repeating sequences such as weekdays, month names, or quarters.

### Linear and Growth Series

When a linear series is created by dragging the fill handle, Microsoft Excel increases or decreases the values by a constant value that is based on the selected starting values. Create a growth series by selecting the **Growth Trend** command on the shortcut menu. Microsoft Excel multiplies the values by a constant factor.

### Activate a Linear Series

Microsoft Excel will increase or decrease a value by a constant value that is based on the selected starting values. The values will grow by adding the step value.

- Type the first number in the series (e.g. 1), press **Enter** and click on the cell again.
- Hold down the **Ctrl** key and with the left mouse button drag the fill handle in the direction you wish the number to increase. The numbers will increase by 1.
Activate a Growth Fill

Since we are dealing with a growth factor, the step value always has to be more than one. (E.g. 1.1 means a growth factor of 10%. The value in the adjacent cell will be 110% of the value in the first cell).

- Type the first number in the series, press Enter and click on the cell again.
- Click and drag the fill handle with the right mouse button.
- A popup menu appears. Click on Series.
- The Series dialog appears:

![Series dialog](image)

- In the Series in box, choose either Columns or Rows and in the Type box, click on the Growth radio button.
- Type in the Step and Stop values and press the Enter key.

Time Saving Features

Microsoft Excel has many features that can save time.

- **AutoComplete** can help you to complete the typing of a word or a phrase.
- Use the **Pick a List** option to select an entry for a cell.
- **AutoCorrect** can correct common typing errors and insert common symbols.
- **Flash Fill** gives you the ability to take a part of the data entered into one column of a worksheet table and enter just that data in a new table column using only a few keystrokes.
AutoComplete

Microsoft Office Excel completes text entries that you start to type in a column of data if the first few letters that you type match an existing entry in that column. If you want to stop automatic completion, you can turn this option off.

- Click the File tab, and then click on Options.
- Click Advanced, and then under Editing options, select or clear the Enable AutoComplete for cell values check box to turn this option on or off.
- Enter data into a cell.
- Click on the cell directly below the existing list.
- As soon as you enter the first character Microsoft Excel will offer the rest of the word.
- At this point continue to enter the rest of the word and then press the Enter key.
- Press the Enter key as soon as the AutoComplete offers to enter the word. The word will be inserted into the cell.
- AutoComplete will only match words or phrases in the same column.

Pick from List

The Pick List option is similar to the AutoCorrect concept. You can quickly pick from a list of existing data, contained in the cells above the active cell.

- Click on the cell directly below the existing cell.
- Click with the right mouse button to display the pop-up menu.
- Select Pick From Drop-down List.
- Select the required item by clicking with the left mouse button.

AutoCorrect

AutoCorrect looks at the entry you are making and checks it against a pre-defined list of common errors. If you make an error on the list, AutoCorrect will replace your entry with the pre-defined correction. AutoCorrect includes an extensive list of commonly misspelled words, but you can customise AutoCorrect to insert long words or phrases when you type a short abbreviation or acronym.

- Click the File tab, and then click on Options.
- Click Proofing ⇒ AutoCorrect Options.
- Use the scroll bars to move through the items in the Replace and With section.
- To turn off AutoCorrect clear the Replace Text As You Type check box.
To undo an AutoCorrect change without turning off AutoCorrect, click the **Undo** button as soon as the AutoCorrect change is made.

### Commonly Misspelled Words

- Click in a blank cell.
- Type **teh** or **adn** followed by a space and then press the **Enter** key.
- When you press the **Spacebar** or **Enter**, the spelling of the word you just typed is automatically corrected.

### Add items to AutoCorrect

- Click the **File** tab, and then click on **Options**.
- Click **Proofing** \(\Rightarrow\) **AutoCorrect Options**.
- The **AutoCorrect** dialog appears:

```
AutoCorrect: English (United States)

AutoCorrect: [ ] AutoFormat As You Type [ ] Actions [ ] Math AutoCorrect

Replace: ___  With: ___

<table>
<thead>
<tr>
<th>b</th>
<th>B</th>
</tr>
</thead>
<tbody>
<tr>
<td>!</td>
<td>!</td>
</tr>
<tr>
<td>&quot;Et doen&quot;</td>
<td>&quot;Et doen dit.&quot;</td>
</tr>
<tr>
<td>&quot;Jan&quot;,</td>
<td>&quot;Jan,&quot;</td>
</tr>
<tr>
<td>1/2</td>
<td>1/2</td>
</tr>
</tbody>
</table>

[Add] [Delete] [OK] [Cancel]
```

- Enter the **incorrect** spelling in the **Replace** box.
- Enter the **correct** spelling in the **With** box.
- Click on the **Add** button.
- The entry is added to the AutoCorrect list.
- Click on **Ok** to finish.
Flash Fill

The Flash Fill feature gives you the ability to take a part of the data entered into one column of a worksheet table and enter just that data in a new table column using only a few keystrokes. The series of entries appear in the new column, literally in a flash, the moment Microsoft Excel detects a pattern in the initial data entry that enables it to figure out the data you want to copy.

Instead of manually entering first, middle, or last names in respective columns (or attempting to copy an entire client name from column A and then editing out the parts not needed in the First Name, Middle Name, and Last Name columns), you can use Flash Fill to quickly and effectively do the job.

- Open the workbook Flash Fill from the training directory.
- Click in cell B2 and type Keith in the cell. Press the Enter key.
- The cell pointer moves to cell B3.
- To use Flash Fill, type only the first letter of the next name.
- In Cell B3, type only J, the first letter of Jonas.
- Flash Fill does an AutoFill suggesting the rest of the first name, Jonas, as the text to enter in this cell.
- Flash Fill also suggests entering all the remaining first names from the full names in column A to column B.
- Complete the entry of Jonas in cell B3 by clicking the Enter button.
- When you complete the data entry in cell B3, the First Name column is done.
- Microsoft Excel automatically enters all the other first names in column B.

Flash Fill Tips

- To convert lowercase values to UPPERCASE, just start typing in UPPERCASE.
- To remove extra spaces from values like addresses, just start typing the addresses without spaces.
- The Flash Fill algorithm for pattern recognition treats numbers and digits the same as text. When working with numbers only, always format the target column as TEXT.
- To get automatic suggestions:
  - You have to edit right next to related data (the next column over from your source data with no blank columns between).
  - You have to make two sequential edits, one right after the other.
Save a Workbook

It is important to save your workbook whenever you start a new project or make changes to an existing one. Saving early and often can prevent your work from being lost. You will also need to pay close attention to where you save the workbook so it will be easy to find later.

- Click the File tab, and then click on Save or use the keyboard shortcut Ctrl + S to save the file.
- If you are saving the file for the first time, you must enter a filename.
- The Save As dialog appears.
- Select the location where you want to save the workbook.
- Enter a descriptive name for the workbook in the File name box.
- Microsoft Excel will automatically add the extension .xlsx to the filename.
- Click on the Save button.

AutoRecover

The AutoRecover function can be used to save workbooks automatically as you work.

- Click the File tab, and then click on Options.
- Click Save and select the Save AutoRecover information every x minutes check box.
- In the Minutes list, specify how often you want the program to save your data.
- The amount of new information that the recovered file contains depends on how frequently a Microsoft Office program saves the recovery file. If the recovery file is saved only every 15 minutes, the recovered file will not contain the last 14 minutes of work before the power failure or other problem occurred.
Click on the Ok button to close the Excel Options dialog.

Exercise 1: Enter text and numbers

Create a new blank workbook and enter the following data in the worksheet:

<table>
<thead>
<tr>
<th>SURNAME</th>
<th>INITIALS</th>
<th>JANUARY</th>
<th>FEBRUARY</th>
<th>MARCH</th>
</tr>
</thead>
<tbody>
<tr>
<td>Wong</td>
<td>JE</td>
<td>46</td>
<td>27</td>
<td>32</td>
</tr>
<tr>
<td>Grey</td>
<td>AB</td>
<td>22</td>
<td>24</td>
<td>29</td>
</tr>
<tr>
<td>Anderson</td>
<td>KE</td>
<td>30</td>
<td>32</td>
<td>34</td>
</tr>
</tbody>
</table>

Save the workbook with the name Overtime Hours in the My Documents\Microsoft Excel Basic 2016 folder.
Microsoft Excel 2016
Basic

Edit a Worksheet

Objectives

After completion of this lesson, you will be able to –

- Cut, copy and paste cells
- Find and replace Information
- Insert and delete cells, rows, columns and worksheets
Edit a Worksheet

Sometimes information is entered in the wrong cells, or the same information must be entered in three different places in a workbook. Instead of deleting and re-entering the information, or entering the same information several times, the data can be moved or copied.

- Open the worksheet Addiction from the training directory.

![Image: Addiction worksheet]

- Click in cell A13 and type Cost of Addiction.
- Save the workbook.

Copy and Paste

- Select the cell or range of cells you want to copy.
- Highlight the cells A4, A5, A6 and A7.
- On the Ribbon, click the Home tab and in the Clipboard group, click the Copy button.

- A line of marching ants appears around the selected text.
Once you see the marching ants, click in cell A15.

To paste the copied text, press the Enter key on your keyboard.

Pasting a cell or range will overwrite any existing data in the target cell or range.

In cell B14 enter the word Price.

In cell C14 enter the word Number.

In cell D14 enter the word Cost.

Enter the following prices in cells B15, B16, B17 and B18 of your spreadsheet: Mars Bars R3.50, Twix R2.90, Bounty R3.20 and Other R4.00.

Save the worksheet.

**Paste with Live Preview Command**

The paste with live preview feature enables you to save time when reusing content within Excel 2016 or across other programs. You can use it to preview various paste options, such as Keep Source Column Widths, No Borders, or Keep Source Formatting. The live preview enables you to visually determine how your pasted content will look before you actually paste it in the worksheet. When you move your pointer over Paste Options to preview results, you will see a menu containing items
that change contextually to best fit the content you are reusing. ScreenTips provide additional information to help you make the right decision.

Preview how pasted contents will look by hovering over the various options on the contextual menu.

![Paste Special Command]

**Paste Special Command**

The Paste Special command allows you to specify exactly what you want to copy. You can use the Paste Special command to copy the resulting value of a formula without copying the formula itself, or to copy the values of a range of cells without any of the formatting options.

- Select the range that you want to copy.
- On the **Ribbon**, click the **Home** tab and in the **Clipboard** group, click the **Copy** button.
- The cell range is copied to the clipboard.
- Click with the right-mouse button on the cell to which you want to copy the selected range and from the shortcut menu click on **Paste Special**:
On the **Ribbon**, click the **Home** tab and in the **Clipboard** group, click the drop down arrow of the **Paste** button and select **Paste Special**.

The **Paste Special** dialog appears on the screen:

The following table describes the **Paste Special Options**:

<table>
<thead>
<tr>
<th>Paste Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>All</td>
<td>Paste all cell contents and formatting.</td>
</tr>
<tr>
<td>Formulas</td>
<td>Paste only formulas as entered in the formula bar.</td>
</tr>
</tbody>
</table>
Paste Option | Description
---|---
Values | Paste only the values as displayed in the cells.
Formats | Paste only cell formatting. Same as Format Painter.
Comments | Paste only comments attached to the cell.
Validation | Paste data validation rules for the copied cells to the paste area.
All except borders | Paste all cell content and formatting applied to the copied cell except borders.
Operations | Specifies which mathematical operation, if any, you want to apply to the copied data.
Skip Blank | Avoids replacing values in your paste area when blank cells occur in the copy area.
Transpose | Changes columns of copied data to rows, and vice versa.
Link | Links the pasted data to the source data.

### Exercise 2: Copy and Paste

Open the workbook **Copy.xls** from the training directory:

- Copy the contents of cells **A1:A6** to cells **A8:A13**.
- Move the contents of cells **C1:C6** to **E1:E6**.
- Copy only the text (no format) of cells **F1:F5** to **B8:B12**.
- Make a copy of **Sheet 2** before **Sheet 5**.
- Use drag and drop to place Sheet 1 between Sheet 2 and Sheet 3.
- Select the range **A1:A6** and move the contents of these cells to **A13**.
- Select the data range **A1:D5** on Sheet 2.
- Click on the **Copy** button.
- Click with the right-mouse button on cell **A1** on Sheet 3.
- Click on **Paste Special** and click on the **Paste Link** button.
- Edit the cell content of cell **A4** on Sheet 2 to Weidemann.
- Activate Sheet 3.
- Save and close the workbook **Copy**.
Insert Command

While working on a worksheet, you may need to insert new cells, columns, or rows. You may also need to delete existing cells, columns or rows from the worksheet. Insert and delete cells by shifting cells or entire rows and columns.

Insert Blank Cells

- Select the cell or the range of cells where you want to insert the new blank cells.
- To insert five blank cells, you need to select five cells.
- On the Home tab, in the Cells group, click the arrow next to Insert, and then click Insert Cells.

The Insert dialog appears:

- Click on Ok to insert the cells.
Insert Rows

- A row or rows are inserted above the selected row.
- Select the row heading or headings where you want to insert the row or number of rows.
- On the Home tab, in the Cells group, click the arrow next to Insert, and then click Insert Sheet Rows.
- Right-click over the selected row(s) and then click on Insert from the pop-up menu. Any existing data in the selected row and the rows below will be moved down to accommodate the new cells.

Insert Columns

- A columns or columns are inserted to the left of the selected column.
- Select the column heading(s) where you want to insert a column.
- On the Home tab, in the Cells group, click the arrow next to Insert, and then click Insert Sheet Columns.
- Right-click over the selected column(s) and then click on Insert from the pop-up menu.
- Any existing data in the selected column and the columns to the right will be moved to the right to accommodate the new cells.

Insert an Entire Worksheet

- To quickly insert a new worksheet at the end of the existing worksheets, click the Insert Worksheet tab at the bottom of the screen.
- The new sheet will be inserted to the right of the active worksheet.
- To insert a new worksheet before an existing worksheet, select that worksheet, and then on the Home tab, in the Cells group, click Insert, and then click Insert Sheet.
- To move the inserted sheet to another position, click on the sheet tab and drag the tab to a new position.
- A black arrow indicates where the sheet will be placed.
Delete Command

When you delete cells, Microsoft Excel removes the cells from the worksheet and shifts the surrounding cells to fill the space. When you clear cells, you remove the cell contents (formulas and data), formats, or comments, but leave the blank cells on the worksheet.

Delete Contents

- Select the cells, rows, or columns you want to clear.
- On the Home tab, in the Editing group, click on the Clear button.
- The following options will appear:

  ![Clear Options](image)

- Click on one of the following options:

<table>
<thead>
<tr>
<th>Select</th>
<th>To</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Clear All</strong></td>
<td>To clear the contents, the format and comments in a selected cell.</td>
</tr>
<tr>
<td><strong>Clear Formats</strong></td>
<td>To clear only the formats of the selected cells. Contents and comments will not be cleared.</td>
</tr>
<tr>
<td><strong>Clear Contents</strong></td>
<td>To clear only the contents of the selected cells. Formats and comments will not be cleared.</td>
</tr>
<tr>
<td><strong>Clear Comments</strong></td>
<td>To clear only the comments of the selected cells. The contents and format will not be cleared.</td>
</tr>
<tr>
<td><strong>Clear Hyperlinks</strong></td>
<td>To clear only hyperlinks of the selected cells.</td>
</tr>
</tbody>
</table>

- Click a cell and press the **Delete** or **Backspace** key, to remove the cell contents but not any comments or cell formats.
- When a cell is cleared, Microsoft Excel removes the content, formats, comments, or all three. The value of a cleared cell is 0 (zero), and a formula that refers to that cell will receive a value of 0.
Delete Cells, Rows or Columns

- Select the cells, rows or columns you want to delete.
- On the Home tab, in the Cells group, click Delete, and then click on the Clear button.
- Select one of the following options:

  ![Delete Cells options](image)

- Any data in the selected cells, rows or columns will be deleted.
- The surrounding cells shift to fill the space.
- Microsoft Excel keeps formulas up to date by adjusting references to the shifted cells to reflect their new locations.
- A formula that refers to a deleted cell displays the #REF! Error value.

Rename and Move Worksheets

It is useful to rename sheets to relate to the contents of the sheet.

Rename

- Select the sheet to be renamed.
- On the Sheet tab, right-click the sheet tab that you want to rename, and then click Rename.

- Select the current name, and then type the new name.
- You can also double click on the sheet name and enter the new name.
Exercise 3: Columns and Rows

Open the workbook *Income.xlsx* and make the following changes to the workbook.

- Insert an open row between the heading **INCOME** and row A2.
- Use the **AutoFill** command to fill columns B, C, D and E with the correct months.
- Delete column E.
- Insert an open row between **Shares** and **TOTAL**.
- Delete all blank rows and columns.
- Save the workbook with the same name.
Microsoft Excel 2016 Basic

Formatting a Worksheet

Objectives

After completion of this lesson, you will be able to –

- Adjust row height and column width
- Format fonts
- Format values
- Align a cell's contents
- Add borders, colours, and patterns to cells
- Merge cells
- AutoFormat a table
- Apply Conditional Formatting
Formatting a Worksheet

The term formatting refers to changing the appearance of a spreadsheet. This includes font and style changes and alignment alterations. You can format text by using the Font group on the Home tab of the Ribbon.

Adjust Column Width

When you start working on a worksheet, all columns are 8.43 characters wide (in default font) and row heights are set to fit the content of the cell with a maximum of 15 points. Microsoft Excel may widen the column or increase the row height to fit the cell content.

If values are entered that do not fit within the displayed boundary of a column width, Microsoft Excel stores the data, but displays number signs (#####) in the cell. To fully display the value, change the column width.

Row heights automatically adjust to accommodate the largest font entered in a row. Column width does not adjust automatically. You can change the standard column width for individual worksheets.

Use one of the following methods to change the column width:

- To change the width of one column, drag the boundary on the right side of the column heading until the column is the width that you want.

- To change the width of multiple columns, select the columns that you want to change, and then drag a boundary to the right of a selected column heading.

- To change the width of columns to fit the contents, select the column or columns that you want to change, and then double-click the boundary to the right of a selected column heading.

- To change the width of all columns on the worksheet, click the Select All button, and then drag the boundary of any column heading.
Select the column or columns that you want to change.
On the Home tab, in the Cells group, click Format.

Under Cell Size, click Column Width.

In the Column width box, type the value that you want.
Select the column or columns that you want to change. On the Home tab, in the Cells group, click Format. Under Cell Size, click AutoFit Column Width.
To change the default column width for a worksheet, click its sheet tab. To change the default column width for the entire workbook, right-click a sheet tab and click Select All Sheets on the shortcut menu.

On the Home tab, in the Cells group, click Format.
Under Cell Size, click Default Width.
In the Default column width box, type a new measurement.
If you enter a number which exceeds the width of a column, ####### signs will be displayed in the cell to indicate that the column is not wide enough.
Adjust Row Height

- To adjust a single row, select any cell from the row to be adjusted. To adjust multiple non-contiguous rows, press Ctrl + select cells from each row to be adjusted.
- On the Ribbon, select the Home command tab. In the Cells group, click the Format button.
- In the Cell Size section, select Height. The Row Height dialog appears:

  ![Row Height Dialog](image)

  - In the Row height text box, type the desired height and click on Ok.
  - The row height is adjusted.

Formatting Cells

In Microsoft Excel, every cell can be formatted differently. There are many options available to customize your Microsoft Excel workbook, which can make the worksheet easier to read. Microsoft Excel also provides many number formats, allowing you to standardize how numbers will appear in your document.

Apply cell styles

Cell Styles are a combination of fill and font colour designed to highlight or emphasize cell contents.

- Select the cell(s) to be formatted.
- On the Home tab, in the Styles group, click the Cell Styles button. A pull down list appears. When you hover the mouse over different styles, a preview of the style will appear in the selected cells.
- From the Good, Bad and Neutral; Data and Model; or Titles and Headings group, select the desired cell style. The style is applied to the selected cells.

Format Borders

To make certain cells stand out in the worksheet, format the borders.
**Change Borders**

- Select the applicable cell(s).
- On the **Home** tab, in the **Font** group, click the drop down arrow next to **Border**.
- Select the desired border. The border is applied.

**Change Border Colour**

- On the **Home** tab, in the **Font** group, click the drop down arrow next to **Border** and select **Line Colour**.
- Select the desired colour. The cursor changes to the shape of a pencil.
- To format individual borders, click the borders you want changed.
- To format multiple cells, click and drag across the desired cells
- To quit formatting border colours, press the **Escape** key.

**Change Border Style**

- On the **Home** tab, in the **Font** group, click the drop down arrow next to **Border** and select **Line Style**.
- Select **Line Style** and then select the desired line style.
- To format individual borders, click the borders you want changed.
- To format multiple cells, click and drag across the desired cells
- To quit formatting border styles, press the **Escape** key.

**Delete Borders**

- On the **Home** tab, in the **Font** group, click the drop down arrow next to **Border** and select **Erase Border**.
- The cursor changes to the shape of an eraser.
- To delete individual borders, click the borders you want changed.
- To delete multiple cell borders, click and drag across the desired cells.
- To quit deleting borders, press the **Escape** key.

**Merge Cells**

Merging cells converts the selected cells into a single cell. This can be useful for creating titles. After a cell merge, if two or more selected cells have data in them, Microsoft Excel will display the information from the cell closest to the upper left corner, deleting all other data.
Select the cells you want to merge.
On the **Home** tab, in the **Alignment** group, click the **Merge & Centre** button.
The cells are merged and the text aligns to the **centre**.

**Customize a Cell Merge**

If you click the drop-down arrow next to the Merge & Center command on the Home tab, the Merge drop-down menu will appear.

- Merge & Center: merges the selected cells into one cell and centres the text.
- Merge Across: merges the selected cells into larger cells while keeping each row separate.
- Merge Cells: merges the selected cells into one cell but does not center the text.
- Unmerge Cells: unmerges selected cells.

Select one of the above options to merge cells:

- Select the cells you want to merge.
- Click the drop down arrow next to **Merge & Centre**. A pull-down list appears.
- To merge cells and align text to the centre, click the **Merge & Centre** button.
- To merge cells only as rows (i.e., columns do not merge), click **Merge across**.
- To merge cells without setting an alignment, click **Merge Cells**.

**Remove a Cell Merge**

- Select the cell you want to unmerge.
- Click the drop down arrow next to **Merge & Centre** and select **Unmerge Cells**.
- The cell merge is removed.

**Wrapping Text**

If you have text that appears in a single cell and you want to increase the height of the cell without expanding the row or column, you can use the Wrap text option.

- Select the appropriate cells.
- On the **Home** tab, in the **Alignment** group, click the **Wrap Text** button.
- The text wrap is applied.
- To remove the text wrap, click the **Wrap Text** button again.
Copy Cell Formatting

If you want to copy only the formatting of a cell use the Format Painter option. The Format Painter formats the destination cell the same as the source cell without changing its content.

- Select a cell or cell range with the formatting you want to copy.
- On the Home tab, in the Clipboard group, click the Format Painter button.
- Select the cell range where you want to apply the copied formatting.
- To copy selected formatting to several locations, select the cell range with the formatting options you want to copy.
- Double-click on the Format Painter button.
- Select the cell range where you want to apply the copied formatting.
- Click on the Format Painter button when you are finished.

Clear Cell Formatting

You can remove all cell formatting while preserving text formatting in selected cells (e.g., fill colour, alignment, and borders will be cleared, but text colour, font size, and font face will not be cleared).

- Select the cell(s) containing the formatting to be cleared.
- On the Home tab, in the Editing group, click the drop down arrow of Clear and select Clear Formats. The cell formatting is removed.

Cell Alignment

By default, the contents of a cell appear at the bottom of the cell, with values (numbers) aligned to the right and labels (text) aligned to the left.

- On the Home tab, in the Alignment group, click the Centre button to centre the selected text inside the cells.
- Select the cell or cell range you want to align.
- Right-click the selection to display the pop-up menu and from the pop-up menu, select Format Cells.
- The Format Cells dialog appears.
- Click the Alignment tab.
Select **Left** (Indent) from the **Text alignment Horizontal** list, and use the spinner controls to add the required indent.

- Click on **Ok**.
- The following table describes the **Alignment Formatting** buttons on the **Formatting** toolbar:

<table>
<thead>
<tr>
<th>Button Name</th>
<th>Example</th>
<th>Formatting</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Align Left]</td>
<td>Left</td>
<td>Aligns the cell contents to the left side of the cell.</td>
</tr>
<tr>
<td>![Centre]</td>
<td>Centre</td>
<td>Centres the cell contents in the cell.</td>
</tr>
<tr>
<td>![Align Right]</td>
<td>Align Right</td>
<td>Aligns the cell contents to the right side of the cell.</td>
</tr>
<tr>
<td>![Decrease Indent]</td>
<td>Indent</td>
<td>Indents the cell contents by one character.</td>
</tr>
<tr>
<td>![Increase Indent]</td>
<td>Indent</td>
<td>Decreases indented cell contents by one character.</td>
</tr>
<tr>
<td>![Wrap Text]</td>
<td>Wrap</td>
<td>Wrap text.</td>
</tr>
<tr>
<td>![Merge &amp; Center]</td>
<td>Centre</td>
<td>Merges the selected cells and centres the cell contents.</td>
</tr>
</tbody>
</table>
**Rotate Text**

- Select the cell or cell range that you want to modify.
- Right click to display the pop-up menu and from the list click on **Format Cells**.
- The **Format Cells** dialog appears.
- Select the **Alignment** tab.
- In the **Orientation** section either enter the exact number of rotation required into the **Degrees** box, or drag the **Text Rotation** tool to give the desired level of rotation.
- Click on **Ok**.

![Orientation](image)

**Default Font**

- Click the drop down button of the **Font** group.
- The **Font** dialog will appear.
- Select a font and a font size in the **Use this font** and **Font Size** boxes.
- Click on **Ok**.
- The new default font and font size are used only in new workbooks created after restarting Microsoft Excel. Existing workbooks are not affected.

**Formatting Numbers**

Number formatting changes how values are displayed. Microsoft Excel provides preset number formats to help standardize how numbers will appear in a worksheet.

**Format Numbers**

Microsoft Excel allows you to quickly format numbers from the Ribbon.

- Select the cell(s) you want to format.
- On the **Home** tab, in the **Number** group, click the drop-down arrow next to the **Number** command.
- The **Number Formatting** drop-down menu will appear:
The following table describes the number formats available:

<table>
<thead>
<tr>
<th>Name</th>
<th>Image</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Number Format</td>
<td>![Image](ABC 1.23 No specific format)</td>
<td><strong>General</strong> is the default format for any cell. When you enter a number into the cell, Excel will guess the number format that is most appropriate.</td>
</tr>
<tr>
<td>Number</td>
<td>![Image](12 Number)</td>
<td><strong>Number</strong> formats numbers with decimal places.</td>
</tr>
<tr>
<td>Currency</td>
<td><img src="Currency" alt="Image" /></td>
<td><strong>Currency</strong> formats numbers as currency with a currency symbol.</td>
</tr>
<tr>
<td>Accounting</td>
<td><img src="Accounting" alt="Image" /></td>
<td><strong>Accounting</strong> formats numbers as monetary values like the Currency format, but it also aligns currency symbols and decimal places within columns. This format makes it easier to read long lists of currency figures.</td>
</tr>
<tr>
<td>Short Date</td>
<td>![Image](Short Date)</td>
<td><strong>Short Date</strong> formats numbers as M/D/YYYY.</td>
</tr>
<tr>
<td>Long Date</td>
<td>![Image](Long Date)</td>
<td><strong>Long Date</strong> formats numbers as Weekday, Month DD, YYYY.</td>
</tr>
</tbody>
</table>
Time formats numbers as HH/MM/SS and notes AM or PM.

Percentage formats numbers with decimal places and the percent sign.

Fraction formats numbers as fractions separated by the forward slash.

Scientific formats numbers in scientific notation.

Text formats numbers as text, meaning that what you enter into the cell will appear exactly as it was entered.

You can easily customize any format in More Number Formats.

Format Numbers: Dialog Box Option

The Format Cells dialog can help you customize your number formatting:

- Select the cell(s) you want to format.
- On the Home tab, in the Number group, click on the Format Cells dialog launcher.
- The Format Cells dialog appears with the Number tab displayed.
- In the Category list, select the desired number format.
- You can preview the formatting in the Sample section.
Click on Ok.
The selected cells are formatted.

**Clear Number Formatting**

The General number format is the default selection. Changing the formatting to General will remove all other number formatting for the selected cells.

- Select the cell(s) you want to format.
- On the Home tab, in the Number group, click the drop-down arrow of Number Format and select General. The formatting is cleared.

**Styles and Built-in Table Formats**

To format an entire list or other large range that has distinct elements - column and row labels, summary totals, and detail data - apply a built-in table design, called Format as Table.

Rather than formatting cells manually, you can also use Microsoft Excel pre-designed cell styles. Cell styles are a quick way to include professional formatting for different parts of your workbook, such as titles, headers, and more. Applying a cell style will replace any existing cell formatting except for text alignment. You may not want to use cell styles if you have already added a lot of formatting to your workbook.

**Apply a Cell Style**

Apply a Cell Style is used to apply a new cell style to existing titles and header cells.

- Select the cell(s) you wish to modify.
- Click the Cell Styles command on the Home tab and then choose the desired style from the drop-down menu.
- Choose Accent 1.
- The selected cell style will appear.
- Applying a cell style will replace any existing cell formatting, except text alignment.
- You may not want to use cell styles if you have already added a lot of formatting to your workbook.

**Format as Table**

Format as Table is a built-in collection of formats such as font sizes, patterns, and alignments you can quickly apply to a cell range or entire worksheet.

- Select the range to be formatted or position the cell pointer anywhere in the table to be formatted.
- On the **Home** tab, in the **Styles** group, click the drop down arrow of **Format as Table** and select one of the pre-defined styles.
Customize the table style by clicking the **New Table Style** button.

### Conditional Formatting

Imagine you have a spreadsheet with thousands of rows of data. It would be extremely difficult to see patterns and trends from examining the raw data. Microsoft Excel gives us several tools that will make this task easier. One of these tools is called conditional formatting. With conditional formatting, you can apply formatting to one or more cells based on the value of the cell. You can highlight interesting or unusual cell values, and visualize the data using formatting such as colours, icons, and data bars.

### Apply Preformatted Rules

Using preformatted rules is a quick way to apply conditional formatting to your worksheet.
Apply Cell Highlighting

You can apply highlighting to cells if they meet the criteria that you set. The criteria can be number-based (greater than, less than, equal to), text-based (text contains, date occurring), or both (duplicate values).

- Select the range of cells to be formatted.
- On the Home tab, in the Styles group, click the drop down arrow of Conditional Formatting.
- A menu will appear with several rules.
- Select the desired rule.
- Select Highlight Cells Rules and then select the desired criteria.
- A dialog will appear. Enter a value in the space provided.
- Select a formatting style from the drop-down menu.
- Click on Ok.
- The formatting will be applied to the selected cells.
- If you want, you can apply more than one rule to your cells.

Apply Top, Bottom, and Average Rules

You can apply conditional formatting to cells that satisfy criteria based on the ten highest or lowest numbers, percentages, or averages.

- Select the range of cells to be formatted.
- On the Home tab, in the Styles group, click the drop down arrows of the Conditional Formatting button.
- A menu will appear with several rules.
- Select the desired rule.
- Select Top/Bottom Rules and then select the desired criterion.
- A dialog appears.
- In the dialog, specify your criteria.
- Click on Ok.
- The rule is applied to cells which satisfy the criteria.

Conditional Formatting Pre-sets

Microsoft Excel has a number of pre-sets that you can use to quickly apply conditional formatting to your cells. They are grouped into three categories: Data Bars, Colour Scales, and Icon Sets.
Data Bars are horizontal bars added to each cell, much like a bar graph. 

Colour Scales change the colour of each cell based on its value. Each colour scale uses a two or three colour gradient. For example, in the Green - Yellow - Red colour scale, the highest values are green, average values are yellow, and the lowest values are red.

Icon Sets add a specific icon to each cell based on its value.

To use Pre-set Conditional Formatting do the following:

- Select the range of cells to be formatted.
- On the Home tab, in the Styles group, click the drop-down arrow of the Conditional Formatting button.
- A drop-down menu will appear.
- Select Data Bars, Colour Scales, or Icon Sets and then select your desired style.
- The rule is applied.

Create a Customized Rule

If you do not want to use one of the preformatted rules, you can create your own using the New Formatting Rule dialog.

- Select the range of cells to be formatted.
- On the Home tab, in the Styles group, click the drop down arrow of the Conditional Formatting button and select New Rule.
- The New Formatting Rule dialog appears:
In the **Select a Rule Type** section, select the condition that will trigger formatting.  
- The **Edit the Rule Description** section will refresh to display new options.  
- In the **Edit the Rule Description** section, select your criteria.  
- The criteria will vary based on the selection made in step 3. To specify the formatting click **Format**.  
- The **Format Cells** dialog appears.  
- Select the desired formatting options and click on **Ok**.  
- The **Format Cells** dialog closes.  
- When finished, click the **Ok** button. The new rule is applied and saved.

---

**Edit Rules**

You can edit preformatted and original rules. Rules are only editable if they have been applied in a worksheet.

- On the **Home** tab, in the **Styles** group, click the drop down arrow of the **Conditional Formatting** button and select **Manage Rules**.  
- The **Conditional Formatting Rules Manager** appears:
On the **Show formatting rules for** pull-down list, select the worksheet containing the rule you want to edit.

- The conditional formatting rules applied in that selection will appear in the dialog.
- From the list, select the rule you want to edit.
- The rule is highlighted.
- Click **Edit Rule**.
- The **Edit Formatting Rule** dialog appears:

![Edit Formatting Rule dialog](image)

- To change what triggers the formatting, from the **Select a Rule Type** section, select the condition.
- The **Edit the Rule Description** section will refresh to display new options.
- To change criteria, in the **Edit the Rule Description** section, select your criteria.
- To change the formatting, click **Format**. The **Format Cells** dialog appears.
- Select the desired formatting options and click on **Ok**.
- The **Format Cells** dialog closes.
When finished, click on **Ok**. The changes are saved.

To close the **Conditional Formatting Rules Manager**, click on **Ok**.

---

**Prioritizing Rules**

When using conditional formatting, it may be necessary to prioritize your rules. If you create a rule to format cells B2–B5 with red fill colour, and you create another rule to format cells B2–E2 with yellow fill colour, the cell B2 will have conflicting formatting. If this happens, both effects may appear, or one rule may simply override the other. With prioritized rules, the rule with higher priority will apply. You can easily adjust priorities through the Conditional Formatting Rules Manager.

- New rules are given the highest priority.
- On the **Home** tab, in the **Styles** group, click the drop down arrow of **Conditional Formatting** and select **Manage Rules**.
- The **Conditional Formatting Rules Manager** appears.

On the **Show formatting rules for** pull-down list, select the worksheet containing the rule(s) you want to prioritize. The conditional formatting rules applied in that selection will appear in the dialog. Rules at the top of the list have the highest priority.

- Select the rule for which you want to change priority. The rule is highlighted.
- To move the rule up by one rule, click the **Move Up** arrow. To move the rule down by one rule, click the **Move Down** arrow. The rule adjusts.
- If you want Microsoft Excel to automatically choose a rule that has a lower priority than its alternatives, for that rule, select **Stop If True**. Not all rules have a **Stop If True** option.
Deleting Rules

Once a rule has been applied, it may be deleted.

- On the Home tab, in the Styles group, click the drop-down arrow of the Conditional Formatting button and select Manage Rules.
- The Conditional Formatting Rules Manager appears:

![Conditional Formatting Rules Manager](image)

- On the Show formatting rules for pull-down list, select the worksheet containing the rule you want to delete. The conditional formatting rules applied in that selection will appear in the dialog.
- Select the rule to delete. The rule is highlighted.
- Click the Delete Rule button. The rule is deleted. Click on Ok. The changes are saved.

Exercise 4: Formatting

- Open the workbook Format.xlsx from the training directory.
- Select the worksheet AutoFormat.
- On the Home tab, in the Styles group, click the drop down arrow of the Format as Table button and select a style.

- Select the worksheet Conditional Format.
- Display all the values between 20 and 30.
- Select the range B4 to H17.
- On the Home tab, in the Styles group, click the drop down arrow of the Conditional Formatting button.
- Click the New Rule button.
- The New Formatting Rule dialog appears:
Click on **Format only cells that contain** and enter the values between 20 and 30.

- Click on the **Format** button and apply a format.
- When entering formulae to the cells, the cell containing a value that matches the criteria will be displayed with the given format.

- Select the worksheet **Format**.
- Adjust the width of column A to 17.
- Centre the heading across columns A to H.
- Click cell B3 and drag the fill handle to automatically fill the rest of the months to H3.
- Change the font, font size and the colour of the heading.
- Display all the numbers with two decimals. Click on **Ok**.
After completion of this lesson, you will be able to –

- Use the AutoSum function
- Enter a formula
- Enter a cell or range reference
- Edit formulas
- Understand a Function
- Enter Functions
- Use the Sum, Average, Count, Max and Min Functions
- Understand relative and absolute cell addresses
- Sub Totals
Formula and Functions

One of the basic functionalities of a spreadsheet is the ability to calculate values based on numeric data. A formula performs calculations such as adding, subtracting, and multiplying. All formulas must start with an equal sign (=). The equal sign tells Microsoft Excel that you want to perform a calculation. This is because the cell contains, or is equal to, the formula and the value it calculates.

It is good to know the limits Microsoft Excel sets on various aspects of formulas and worksheet models, even though it is unlikely that you will ever bump up against these limits. Formula limits

<table>
<thead>
<tr>
<th>Object</th>
<th>Excel 2016 maximum</th>
<th>Excel 2003 maximum</th>
</tr>
</thead>
<tbody>
<tr>
<td>Columns</td>
<td>16,384</td>
<td>1,024</td>
</tr>
<tr>
<td>Rows</td>
<td>1,048,576</td>
<td>65,536</td>
</tr>
<tr>
<td>Formula length (characters)</td>
<td>8,192</td>
<td>1,024</td>
</tr>
<tr>
<td>Function arguments</td>
<td>255</td>
<td>30</td>
</tr>
<tr>
<td>Formula nesting levels</td>
<td>64</td>
<td>7</td>
</tr>
<tr>
<td>Array references (rows or columns)</td>
<td>Unlimited</td>
<td>65,335</td>
</tr>
<tr>
<td>PivotTable columns</td>
<td>16,384</td>
<td>255</td>
</tr>
<tr>
<td>PivotTables rows</td>
<td>1,048,576</td>
<td>65,536</td>
</tr>
<tr>
<td>PivotTables fields</td>
<td>16,384</td>
<td>255</td>
</tr>
<tr>
<td>Unique PivotTable items</td>
<td>1,048,576</td>
<td>32,768</td>
</tr>
</tbody>
</table>

Arithmetic Operators

Excel uses standard operators for formulas, such as a plus sign for addition (+), a minus sign for subtraction (-), an asterisk for multiplication (*), a forward slash for division (/), and a caret (^) for exponents.
AutoSum

The AutoSum command allows you to automatically insert the most common functions into your formula, including SUM, AVERAGE, COUNT, MIN, and MAX.

- Click in the cell where you want to insert the total.
- On the Formulas tab, in the Function library group, click the drop down arrow of the AutoSum button and select Sum.
- Microsoft Excel 2016 inserts the SUM function which adds all the values in a range of cells.
- Microsoft Excel is smart enough to determine which cells you want to total, however if the suggested range is incorrect, select the correct range and then press the Enter key.
- Double-click the AutoSum button to automatically complete the summation for a single row or column of values.
- When a range of formula cells is selected, only click the AutoSum button once.
- When the results of a summation, or other function, are too large to display in a standard width column, Microsoft Excel automatically adjusts the column width.

Enter a Formula

A formula performs calculations, such as adding, subtracting and multiplying. Formulas start with the equal sign (=), which tells Microsoft Excel that you want to perform a calculation. After the equal sign, you must specify the following information: the values you want to calculate and the arithmetic operator(s) or function names you want to use to calculate the values.

While typing cell references, keep in mind that the calculations will be done using the values present in the particular cells entered, not with the cell references themselves. The following formula multiplies 2 by 3 and then adds 5 to the result: =5+2*3

There are some basic concepts to understand before starting to create formulas:

- Click in the cell where the answer is to be displayed.
- Type an equal sign (=). This informs Microsoft Excel that a mathematical label is entered.
- Enter the first argument. An argument can be a number or a cell reference. Type in the references to cells on the worksheet, or select the desired cells to define the arguments.
- Enter an arithmetic operator.
- Enter the next argument.
- Press the Enter key to calculate the result.
- The calculated value of a formula is displayed in the worksheet cell.
- To change the order of evaluation, enclose in parentheses the part of the formula to be calculated first.
- Display the formula in the Formula bar by clicking on the cell that contains the formula.

**Tips**

- Be careful not to include the formula's cell address in the formula's arguments itself. This creates a circular reference, and Microsoft Excel will display an error message.
- If the numeric keypad is used to enter numbers and math symbols, press the Num Lock key to toggle the numeric keypad on or off.
- Every operator in a formula must be a valid mathematical operator.
- A cell contains the formula but displays only the results.
- To see the formula and not the actual value in a cell, double click on the cell.

**Cell/Range Reference**

While you can create simple formulas in Microsoft Excel manually (for example, =2+2 or =5*5) most of the time you will use cell addresses to create a formula. This is known as making a cell reference. When a formula contains a cell address, it is using...
a cell reference. Using cell references will ensure that your formulas are always accurate, because you can change the value of referenced cells without having to rewrite the formula.

- Instead of typing in a cell reference, you can use the arrow keys to move to the desired cell.
- To create a reference, select a cell, a range of cells, a location in another worksheet, or a location in another workbook.
- You can drag the border of the cell selection to move the selection, or drag the corner of the border to expand the selection.
- Instead of typing in a range reference, you can use the arrow keys to select the desired range. Begin by moving the cell pointer to the first cell in the range. Enter a period (.) to mark the beginning of the range, and move the cell pointer to the last cell in the range.
- You can also use the mouse to select the cell or range reference. When referring to a cell or range that is not on the same worksheet as the formula, the sheet name and the exclamation mark (!) appear in front of the cell/range reference.
- Press the Enter key to return to the formula.

By combining a mathematical operator with cell references, you can create a variety of simple formulas in Microsoft Excel. Formulas can also include a combination of cell references and numbers, as in the examples below:
Functions

Functions are used in formulas to perform calculations that are more complicated. Microsoft Excel provides a wide range of predefined formulas called functions to help you to quickly set-up simple and complex calculations. Functions are formula shortcuts that only require the values or arguments needed for the specific calculation.

- The structure of a function begins with an equal sign, followed by the function name.
- Functions always include an opening parenthesis, the arguments for the function separated by commas, and a closing parenthesis.
- For a list of available functions, click a cell and press Shift + F3.
- Arguments can be numbers, text, logical values such as TRUE or FALSE or constants.

Insert Functions

There are multiple ways to create a function. You can insert functions by typing them, or you can use the Insert Function dialog. The Insert Function dialog eliminates the possibility of a typing error, so it is the recommended method.

- Click in the cell where you want to insert the function.
- Press the = (the equal sign) to begin any formula or function.
- Enter the function name followed by an opening parenthesis.
- Enter the arguments (the values that a function uses to perform operations or calculations), separated by commas, and a closing parenthesis.
- Press the Enter key to calculate the result.
The following table describes examples of basic operators, references, formulas and basic functions covered in this course:

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>=</td>
<td>All formulas must start with an equal sign.</td>
</tr>
<tr>
<td>+</td>
<td>Performs addition between values.</td>
</tr>
<tr>
<td>-</td>
<td>Performs subtraction between values.</td>
</tr>
<tr>
<td>*</td>
<td>Performs multiplication between values.</td>
</tr>
<tr>
<td>/</td>
<td>Performs division between values</td>
</tr>
<tr>
<td>SUM</td>
<td>Adds all the numbers in a range.</td>
</tr>
<tr>
<td>AVERAGE</td>
<td>Calculates the average of all the numbers in a range.</td>
</tr>
<tr>
<td>COUNT</td>
<td>Counts the number of items in a range.</td>
</tr>
<tr>
<td>MAX</td>
<td>To return the highest number in the list of arguments.</td>
</tr>
<tr>
<td>MIN</td>
<td>To return the lowest number in the list of arguments.</td>
</tr>
<tr>
<td>TODAY</td>
<td>To insert today's date.</td>
</tr>
<tr>
<td>ROUND</td>
<td>To round a number to a specified number of digits.</td>
</tr>
</tbody>
</table>

**Insert Function Dialog**

The Insert Function dialog makes it easy to determine what functions are available, which function you should be using, and what you need to include in the function. It displays a listing of all functions or categories of functions available with Microsoft Excel. As you select a function, a sample of the function appears at the bottom of the dialog. As you make your selection, the Insert Function dialog will request certain types of information; you will simply need to select the cells where that information is located.

- Select the cell where the function should be added
- On the Ribbon, select the Formulas tab. In the Function Library group, click the Insert Function button.
- The Insert Function dialog appears:
From the **Or select a category** pull-down list, select the appropriate function category or select the option **Select All**.

From the **Select a function** scroll box, select the desired function. A description of the selected function appears beneath the **Select a function** scroll box.

Click on **Ok**.

The **Function Arguments** dialog appears:

The appearance and options available in the **Function Arguments** dialog will differ depending on which function has been chosen. A function's arguments are the value(s) that the function is being performed upon.

In the **Number** text boxes, type the data to be used in the function or select the ranges by clicking the **Collapse Dialog** button.

Click and drag to select the desired cell and click the **Restore Dialog** button.

Click on **Ok**. The results of the function will appear in the selected cell.
### Point and Click Method

Functions based on cell references can be created by clicking the cells rather than typing the cell entries. This **point and click** method can help reduce the chance of error in the functions and may be easier for some users. The key to the point and click method is to click the cells to be included and type the operators where appropriate.

All functions that can be accessed from the **Insert Function** dialog can be typed with a text-based command. If you choose to type your function into a cell, however, be sure that you know precisely how to enter information for the function, especially if you are working with a complex function.

The following examples provide step-by-step instructions for a simple addition of two cells and for adding a range of cells.

#### Adding Cells Together:

- Select the cell where the results should be displayed.
- To start the function, press the = sign.
- Click the first cell to be added.
- Press the + sign.
- Click the next cell to be added.
- Press the **Enter** key.
- The sum appears in the selected cell.

#### Adding a Range of Cells with the SUM Function:

- Select the cell where the results should be displayed.
- To start the function, type the equal sign (=).
- Type `SUM(`
- Select the cell that you wish to reference first in the formula.
- You can also click the first cell in the range to be added, press the : and then click the last cell in the range to be added.
- Type `)` and press the **Enter** key on your keyboard.
- The formula will be calculated and the value will be displayed in the cell.
Move/Copy a Formula/Function

When a formula is **moved**, the cell references within the formula does **not** change. When you **copy** a formula, absolute cell references do not change, relative cell references will change.

- Select the cell that contains the formula or function to be moved or copied.
- Point to the border of the selection.
- To move the cell, drag the selection to the upper-left cell of the paste area.
- Microsoft Excel replaces any existing data in the paste area.
- To copy the cell, hold down the **Ctrl** key while dragging.
- Copy formulas and functions into adjacent cells by using the **Fill handle**.
- Select the cell that contains the formula or function, and drag the fill handle over the range to be filled.

Absolute, Relative and Mixed Cell References

There are three types of cell references: relative, absolute and mixed. Relative and absolute references behave differently when copied and filled to other cells. Relative references change when a formula is copied to another cell. Absolute references remain constant, no matter where they are copied.
**Relative references** tell Microsoft Excel how to find another cell starting from the cell that contains the formula. Relative references are the default type of references used in Microsoft Excel. When a formula containing a relative cell reference is copied, the cell reference automatically **adjusts** so that the relative position does not change. Relative references **update** when formulas are copied. If you copy the formula, =C6/C7 one cell to the right, the new formula becomes =D6/D7. This is because the references are relative to the formula’s position.

**Absolute references** always refer to the **same** cell address, even if the formula is moved. Absolute references are indicated by a dollar ($) sign preceding the row or column heading that is absolute. Absolute references **do not update** when copied or moved. They reference the same cell address, no matter where the formula is. If you copy the formula =C10/$B$9 one cell to the right, the new formula becomes =D10/$B$9. Only the relative part of the formula adjusts; the absolute reference remains fixed on a specific cell address.

**Mixed reference**: A mixed reference has either an absolute column and relative row, or absolute row and relative column. An absolute column reference takes the form $A1$ or $B1$. An absolute row reference takes the form A$1$ or B$1$. If the position of the cell that contains the formula changes, the relative reference is changed, and the absolute reference does not change. If you copy or fill the formula across rows or down columns, the relative reference automatically adjusts, and the absolute reference does not adjust. If you copy or fill a mixed reference from cell A2 to B3, it adjusts from =A$1$ to =B$1$.

- Press **F4** to cycle through the cell reference types while editing arguments in the contents box and worksheet cells.
- Apply absolute referencing to a formula’s arguments before copying the formula to adjacent cells. Microsoft Excel will display error messages if it cannot calculate a result, even though a formula’s arguments may be valid.
- If necessary, absolute referencing can be applied to all arguments to ensure that no relative referencing occurs.

<table>
<thead>
<tr>
<th>Reference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>$A$2</td>
<td>The column and the row do not change when copied</td>
</tr>
<tr>
<td>A$2</td>
<td>The row does not change when copied</td>
</tr>
<tr>
<td>$A$2</td>
<td>The column does not change when copied</td>
</tr>
</tbody>
</table>
Exercise 5: Formula & Functions

- Open the workbook *Family.xls* from the training directory:
- Centre the heading across columns A to H. **AutoFill** row 3 with the months and bold the headings. Adjust the width of column A to 22.
- Bold print the contents of cell A14 (Total Expenses) as well as cell A18 (Total Income).
- Use the **AutoSum** function and calculate the total expense for each month in row 14.
- Use the **Fill** handle to copy the function to cells C14 to G14.
- Use the **AutoSum** function and calculate the total income for each month in row 18. Use the fill handle to copy the function to cells C18 to G18.
- Calculate the **Monthly excess** for each month in row 20.
- Use the **Fill handle** to copy the function to cells C20 to G20.
- Calculate the **Maximum Monthly Expense** and use the fill handle to copy the function.
- Calculate the **Minimum Monthly Expense** and use the fill handle to copy the function.
- Calculate the **Number of Expenses** per month and use the fill handle to copy the function.
- Calculate the **Average of the Expenses** per month and use the fill handle to copy the function. Save and close the workbook.

Exercise 6: Formula & Functions

- Open the workbook *Office.xls* from the training directory:
- Calculate the **Total Price** for each of the items.
- Use the discount rate in cell **B3 (absolute cell address)** and calculate the **Discount** for each of the items.
- Calculate the **Net Price** for each of the items.
- Calculate the **Total Quantity** for all of the items.
- Calculate the **Total Invoice Net Price** amount.
- Save and close the workbook.

Exercise 7: Formula & Functions

- Open the workbook *Forecast.xls* from the training directory:
- Use the growth factor in cell **B11 (absolute cell address)** and calculate the **Sales** for February, March, April, May and June.
Use the cost factor in cell B12 (absolute cell address) and calculate the **Cost** for January, February, March, April, May and June.

Calculate the **Gross Profit** for January to June.

Use the expense factor in cell B13 (absolute cell address) and calculate the **Expense** for January, February, March, April, May and June.

Calculate the **Income** from January to June.

In column H calculate the **Totals**.

Save and close the workbook.
Microsoft Excel 2016
Basic

Working with Lists

Objectives

After completion of this lesson, you will be able to –

- Create a list
- Sort a list
- Use the AutoFilter to filter a list
Working with Lists

In Microsoft Excel lists are organized by records. The first step in creating a list is entering the field names for the list. The field names must be positioned in the first row of the list. Avoid putting blank rows and columns in the list.

Sort a List

Microsoft Excel can sort records alphabetically, numerically, or chronically (by date). Excel can sort the information in ascending (A to Z) or descending (Z to A) order. When sorting data, it is very important to first decide if you would like the sort to apply to the entire worksheet or just a cell range.

- **Sort sheet** organizes all of the data in your worksheet by one column. Related information across each row is kept together when the sort is applied. If you have columns with related information, select the whole range.
- **Sort range** sorts the data in a range of cells, which can be helpful when working with a sheet that contains several tables. Sorting a range will not affect other content on the worksheet. If it is only one column that must be sorted, select a single cell in the column.

The sort command arranges rows in a list according to the contents of particular columns. Microsoft Excel uses specific sort orders to arrange data according to the value and not the format, of the data.

- On the Home tab, in the Editing group, click the Sort & Filter drop down arrow.
- Click the Custom Sort option.
- The Sort dialog appears:
Select the **My data has headers** box if you have a header row.

Under **Column**, select the field on which you want to sort.

Microsoft Excel will place the field name of the selected cell in the **Sort by** text box.

Click on the **Add Level** button to add a second criterion.

---

### Data Filters

**Filters** can be used to **narrow down** the data in your worksheet, allowing you to view only the information that you need. Microsoft Excel provides two commands for filtering lists:

- **AutoFilter** includes filter by selection, for simple criteria.
- **Advanced Filter** for more complex criteria.
- Filtering does not rearrange a list.
- Filtering temporarily hides rows you do not want displayed.
- When Microsoft Excel filters rows, you can edit, format, chart, and print the list subset without rearranging or moving it.

---

### AutoFilter

AutoFilters are simple to use, but have limitations. AutoFilter allows you to view only those records that meet certain specified criteria.

- In order for filtering to work correctly, your worksheet should include a **header row**, which is used to identify the name of each column.
- Click on any cell within the list.
- On the **Home** tab, in the **Editing** group, click the **Sort & Filter** drop down arrow.
- Click the **Filter** option.
- A **drop-down arrow** will appear in the header cell for each column.
- Click the **drop-down arrow** for the column you wish to filter.
- The **Filter** menu will appear.
- Uncheck the box next to **Select All** to quickly deselect all data.
- **Check** the boxes next to the data you wish to filter, then click on **Ok**.
- The data will be filtered, temporarily hiding any content that does not match the criteria.
- Use custom **AutoFilter** to display rows that contain either one value or another.
- **Select All** from the drop-down controls to remove the search criteria and redisplay all the records.
Slicers

Slicers are visual filters. Using a slicer, you can filter your data by clicking on the type of data you want. In Excel 2013 and 2016, you can add a slicer to either pivot tables or regular tables.

- When you add a slicer to regular Excel tables, they act like auto-filters and filter your table data.
- On the Ribbon, click the Insert tab and click on the Insert Slicer button.
- You can select a single item or multiple items in slicers.
- To multi-select, if the items you want are together, just drag from first item to last.
- If the items you want are not together, hold the Ctrl key and click on one at a time.

Exercise 8: Lists

- Open the workbook Marks.xls from the training directory.
- Select the sheet Marks.
- Sort the list of names alphabetically according to the surname in column A and then the initials in column B.
- Add the following comment to the heading Average: Average of two test marks.
- Calculate the average of the two test marks for each student.
- Create a filter to display all the marks with an average between 45 and 50.
- Remove all the filters.
- Save and close the workbook.

Exercise 9: Filters

- Open the workbook Marks.xls from the training directory.
- Select the sheet Filter.
- Sort the list of book names alphabetically according to the Salesperson.
- Calculate the Total Price for each of the books.
- Create a filter to display all the books sold by the Salesperson David.
- Remove all the filters.
- Save and close the workbook.

Subtotals

When sorting data in a list, Microsoft Excel enables you to summarise the data with subtotals. When a list is summarised, Microsoft Excel calculates subtotals based on
subsets of the data and also calculates a grand total. With this feature, you can collapse and expand the detailed items.

The **Subtotal** command allows you to automatically create groups and use common functions like SUM, COUNT, and AVERAGE to help summarize your data.

Your data must be **correctly sorted** before using the Subtotal command

**Create Subtotals**

- Begin by grouping the rows you want to subtotal together by using the **Sort** command.
- On the **Ribbon**, click the **Data** tab and in the **Sort & Filter** group, click the **Sort** button.
- The **Sort** dialog appears.
- Click on **Custom Sort** and sort the table according to the **Salesperson**.
- On the **Ribbon**, click the **Data** tab and in the **Outline** group, click the **Subtotal** button.
- The **Subtotal** dialog appears:

```
Subtotal

At each change in:
Salesperson

Use function:
Sum

Add subtotal to:
- [ ] Book Name
- [ ] Quantity
- [ ] Price (R)
- [ ] Total (R)
- [ ] Salesperson

- [ ] Replace current subtotals
- [ ] Page break between groups
- [ ] Summary below data

Remove All   OK   Cancel
```

- Select the column that contains your subtotal groups from the **At Each Change In** dropdown list.
- Select the calculation you want to perform from the **Use** function dropdown list.
- You can also select average, count, and other summary functions.
Select the column(s) you want to calculate by checking the checkboxes in the **Add Subtotals** to list box.

Select any of the following options:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Replace current subtotals</td>
<td>Replaces any existing subtotals in the list with the new subtotals.</td>
</tr>
<tr>
<td>Page break between groups</td>
<td>Inserts page breaks automatically after each group of subtotalled data.</td>
</tr>
<tr>
<td>Summary below data</td>
<td>Inserts the subtotal and grand total rows below the detail data.</td>
</tr>
</tbody>
</table>

Click on **Ok** to create the subtotals and return to the worksheet.

The worksheet will be **outlined** into **groups** and the **subtotal** will be listed below each group.

---

**To View Groups by Level**

When you create subtotals, your worksheet it is divided into different levels. You can switch between these levels to quickly control how much information is displayed in the worksheet by clicking the Level buttons to the left of the worksheet.

Microsoft Excel can accommodate up to eight levels.
Microsoft Excel displays subtotalled data in **Outline** view.

In this view you can control the amount of data to be displayed.

To display only the subtotal, select the **Hide Detail Level** button for that subtotal. Microsoft Excel hides the detail and displays only the summary data.

To restore the data detail, select the **Show Detail Level** button.

Microsoft Excel displays the full detail again.

To make use of the **button, click on:**

- Click on 1 to see only the grand total. Click the lowest level to display the least detail.
- Click on 2 to see the individual totals.
- Click on 3 to see all the data. Click the **highest level** to view and expand all of your worksheet data.

---

**Remove Subtotals from a List**

- To remove subtotals from a list, select a cell in the subtotalled list.
- On the **Ribbon** click the **Data** tab and in the **Outline** group click the **Subtotal** button to open the **Subtotal** dialog box.
- Click the **Remove All** button to restore the original list.
- To remove all groups without deleting the subtotals, click the **Ungroup** command drop-down arrow and then choose **Clear Outline**.

---

**Exercise 10: Subtotals**

- Open the workbook **Marks.xls** from the training directory.
- Click the sheet tab **Subtotals**.
- Sort the list on the **Salesperson**.
- On the **Ribbon** click the **Data** tab and in the **Outline** group click the **Subtotal** button to open the **Subtotal** dialog box.
- In the **At each change in** box, select **Salesperson**.
- Select the **Sum** function.
- Add subtotals to **Quantity** as well as the **Total**.
- Save and close the file.
Microsoft Excel 2016
Basic

Manage Workbooks

Objectives

After completion of this lesson, you will be able to –

- Work with several worksheets and workbooks
- Split and Freeze a window
- Hide columns, rows and sheets
- Protect
Manage Workbooks

Financial and numeric information often does not fit on a single page. In Microsoft Excel every workbook contains several worksheets. New workbooks automatically contain three blank worksheets.

One of the benefits of Microsoft Excel is that you can open and work with several files at once. Each workbook you open in Microsoft Excel gets its own window.

View Multiple Windows

- On the View tab, in the Window group, click the Arrange All button.
- The Arrange Windows dialog appears on the screen:

  ![Arrange Windows dialog](image)

- Select Vertical and click on Ok.
- Microsoft Excel displays the open files in two vertically aligned windows.
- Click the Close button of one of the open workbooks to close the workbook.

Freezing Panes

When the worksheet becomes larger, not all the data on the worksheet is visible. As you scroll through the worksheet to look at different parts of the worksheet, you lose the reference points at the beginning of the worksheet.

With Microsoft Excel, freezing panes means that both the row(s) and column(s) above and to the left of the cell pointer are locked into place and display no matter where you scroll in the worksheet. Position the cell pointer before activating this command as the titles will take place to the left, and above from where the cell pointer is.
Position the cell pointer at the location where the titles are to be set.
On the View tab, in the Window group, click the Freeze Panes button.
The following options will appear:

Select the applicable option.
Information in the frozen panes remains on the screen as you scroll and move through a worksheet.

Unfreeze Panes

The position of the cursor is not important.
On the View tab, in the Window group, click the Freeze Panes button.
Select Unfreeze Panes.

Hide and Display Rows/Columns

When presenting or printing a spreadsheet, you may not want to include all the detailed calculations. You can present a summary by hiding some of the columns or rows without losing the detailed information. Hidden items will not print when the worksheet is printed.

Hide a Column/Row

Click the column or row heading to select the row or column you want to hide.
On the Home tab, in the Cells group, click Format.
Under Visibility, point to Hide & Unhide, and then click Hide Rows or Hide Columns.
Under Cell Size, click Row Height or Column Width, and then type 0 in the Row Height or Column Width box.
The hidden row or column will not be visible on the screen.
Display Hidden Rows/Columns

- Select the row above and below the rows that you want to display or select the columns adjacent to either side of the columns that you want to display.
- To display the first hidden row or column on a worksheet, select it by typing A1 in the Name Box next to the formula bar.
- On the Home tab, under Editing, click Find & Select, and then click Go To.
- In the Reference box, type A1, and then click Ok.

Protect your Work

If other users will be using your worksheet, it may be wise to restrict them from making any changes to the content of a worksheet. Locking cells or hiding formulas has no effect unless the worksheet is protected. A password is optional.

When you are protecting your workbook, you have two primary options:

- Prevent data entry for select cells - Users can access the worksheet and view the information; however, access for making changes is restricted.
- Restrict or prevent access to the file - Users can be prevented from viewing the worksheet, or users can view the workbook but not make changes to it.

Locking Cells

Microsoft Excel can protect cells, graphics, charts, and other worksheet objects. This protection will take effect only after you turn on the Worksheet Protection option in the Protect Sheet dialog. If you enable protection, no changes can be made to a cell until you unlock that cell.

By default, all cells in Microsoft Excel are locked. You can easily unlock all the cells in Microsoft Excel and then lock specific cells in a worksheet. Make sure to lock the cells before you protect the sheet or document. Once a sheet or a document has been protected, you cannot access menu selections that allow you to make changes to cells.

- Select the cell(s) to be unlocked.
- On the Ribbon, select the Home tab and in the Cells group, click the drop down arrow of the Format button.
- In the Protection section, deselect Locked.
- You can either protect the sheet or select cells to lock.
If the icon is highlighted, the cells are locked.

**Protect Worksheet**

- On the **Ribbon**, select the **Home** tab and in the **Cells** group, click the drop down arrow of the **Format** button.
- In the **Protection section**, select **Protect Sheet**.
- The **Protect Sheet** dialog appears:

![Protect Sheet dialog box](image)

- In the **Protect Sheet** dialog box, select the appropriate options:
  - **Protect worksheet and contents of locked cells** - Prevents changes to locked cells.
  - **Password to unprotect sheet** - Allows only those who know the assigned password to unprotect the worksheet.
  - **Allow all users of this worksheet to** - Checked boxes are aspects that any user can access.
- Click on **Ok**. The worksheet is protected.

**Unprotect a Worksheet**

- On the **Ribbon**, select the **Home** tab and in the **Cells** group, click the drop down arrow of the **Format** button.
- In the **Protection section**, select **Unprotect Sheet**.
- The worksheet is unprotected. Users can now modify the worksheet.
If you included a password when you turned the protection on, you must type the password in the **Password** text box to turn the protection off.

Comments

Comments are pop-up notes that you can insert into your worksheet. Comments can be used for adding notes for other users, adding reminders and creating cross-references to other reports. After adding a comment to your worksheet, you can decide how and where you would like to display that comment, when to print it, and whether to delete comments.

Adding a comment to a cell allows you to append additional information to that cell in a pop-up message. The comment, along with the username of the person who inserted the comment, appears when you point to the cell.

**Add a Comment: Ribbon Option**

- Select the cell to which the comment will be added.
- On the **Ribbon**, click the **Review** tab and in the **Comments** group, click the **New Comment** button.
- The **Comment** box appears, displaying your username.
- Type your comment. When finished, click in another cell. A red triangle appears in the upper right-hand corner of the cell indicating a comment has been attached. When you place your mouse over the cell, the comment appears.

![Cell with comment](image)

**Cell with comment**

![Text of comment revealed](image)

**Text of comment revealed**

**Add a Comment: Mouse Option**

- Right click the cell to which you want to add a comment and from the popup menu, click **Insert Comment**. The **Comment** box appears, displaying your username. Type your comment. When finished, click another cell.
- A **red triangle** appears in the upper right-hand corner of the cell indicating a comment has been attached. When you place your mouse over the cell, the comment appears.
Edit a Comment: Ribbon Option

Editing a comment allows you to change or add to the information you have placed within a cell as a comment.

- Select the cell that contains the comment to be edited.
- On the Ribbon, click the Review tab and in the Comments group, click the Edit Comment button.
- The Comment box appears, containing the text of the comment.
- Make the appropriate changes to the comment and click another cell.

Edit a Comment: Mouse Option

- Right click the cell which contains the comment and from the popup menu, click the Edit Comment option.
- The Comment box appears, containing the text of the comment.
- Make the appropriate changes to the comment
- When finished, click another cell

Hide/Display Comments: Single Cell

- To display a comment, right click the cell which contains the comment and from the popup menu select the Show/Hide Comments option.
- That comment is displayed.
- To hide a comment which has been displayed, right click the cell which contains the comment and from the popup menu select the Hide Comment option. That comment is hidden until you place your mouse over the cell.

Hide/Display Comments: Ribbon Option

- Select the cell which contains the comment.
- On the Ribbon, click the Review tab.
- In the Comments group, click the Show/Hide Comment button.
- When you click to show, the comment appears next to the selected cell.
- When you click to hide, the comment disappears.

Hide/Display Comments: All Cells

- On the Ribbon, click the Review tab.
- In the Comments group, click the Show All Comments button.
This button acts as a toggle switch. Clicking the button once will display your comments: clicking it again will hide all comments.

### Move Comments

If your comments are overlapping text that you would like to read, you can move the comment to a more convenient place. The comment will still remain attached to the cell it was originally created for, but you will be able to move it to a more suitable location.

- Display the comment you would like to move.
- Move your mouse over the border of the comment.
- The pointer becomes a four-headed arrow.
- Click and hold the border of the comment.
- Drag the comment to the desired position. An arrow appears, connecting the comment to the cell. Release the mouse button.

### Delete Comments

Deleting comments allow you to either remove the comment you have placed within an individual cell, or to remove all of the comments you have placed within a document.

#### Remove Comments from a Single Cell: Mouse Option

- Right click the cell which contains the comment and from the popup menu select Delete Comment.

#### Remove Comments from a Single Cell: Ribbon Option

- Select the cell which contains the comment to be deleted.
- On the Ribbon, click the Review tab and in the Comments group, click the Delete Comment button.

#### Remove Comments from All Cells

- Open the sheet with the comments to be deleted.
- On the Ribbon, click the Home tab and in the Editing group, click the drop down arrow of the Find & Select button.
Select Comments.
All comments on the active sheet will be selected.
In the Editing group, click the drop down arrow of the Clear button and select the option Clear Comments.
All comments are cleared.

Print Comments

Comments must be displayed before printing.

Open the worksheet that contains the comments you want to print.
On the Ribbon, click the Page Layout command tab.
In the Page Setup group, click the Page Setup dialog launcher.
The Page Setup dialog appears.
Click the Sheet tab.

In the Print section, from the Comments pull-down list, select the desired option:
- **At end of sheet** - Prints all comments separately, as a group at the end of the printed document. These comments will display a cell reference to inform you of which cell they are attached to.

- **As displayed on sheet** - Prints all displayed comments as they appear in your document. These comments may extend past the page when printed. However, it is possible to avoid this by using the Page Layout view and making sure to move the comment boxes within the printable area of the page.

- Click the **Print** button.
- The **Print** dialog appears.
- Make the appropriate selections and click on **Ok**.

**Exercise 11: Manage Workbooks**

- Open the workbook **Bigsheet.xlsx** from the training directory.
- **Freeze** the panes horizontally and vertically. Scroll through the data.
- **Hide** the columns with the information for 1997 and 1999.
- Unhide all the columns.
- Unfreeze the panes.
- Save and close the workbook.
Microsoft Excel 2016 Basic

Create Charts

Objectives

After completion of this lesson, you will be able to –

- Know the Charting Rules
- Create and edit charts
Introduction

In Microsoft Excel 2016 six new graph types are introduced to help people to get more done without leaving Microsoft Excel. These six charts are used in statistical analysis (box, whisker plot and histograms). Commonly used charts (waterfall, Pareto, Treemap and Sunburst) are now available in Excel 2016.

With Recommended Chart, Microsoft Excel recommends the most suitable charts for your data. Get a quick peek to see how your data looks in the different charts, and then simply pick the one that shows the insights you want to present.

Charting Rules

Microsoft Excel follows seven basic rules for creating charts. Understanding these rules can help avoid frustration and reduce the steps necessary for creating charts. Once the chart is created, you can modify it to meet your needs.

<table>
<thead>
<tr>
<th>Rule</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rule 1</td>
<td>Excel does not automatically add a chart title to your chart based on the first row of selected information. A chart title can be added during the creation process or later.</td>
</tr>
<tr>
<td>Rule 2</td>
<td>Excel does not automatically add a chart subtitle to your chart based on the second row of selected information. A subtitle can be added after the chart is created.</td>
</tr>
<tr>
<td>Rule 3</td>
<td>Blank rows and columns in your information are not ignored. Excel will leave a blank bar or pie slice for every blank row or column in your information.</td>
</tr>
<tr>
<td>Rule 4</td>
<td>If the data contains more rows than columns, Excel will plot the data by column. The first column becomes the x-axis labels; the balance of the columns is the data series. The first row becomes the legend's labels.</td>
</tr>
</tbody>
</table>
Rule | Description
--- | ---
**Rule 5** | If the data contains more columns than rows, Microsoft Excel will plot the data by row. The first row becomes the x-axis labels; the balance of the rows is the data series. The first column becomes the legend's labels.

**Rule 6** | If the data contains an equal number of rows and columns, Microsoft Excel defaults to plot the data by rows but gives you the option to plot by columns.

**Rule 7** | If only numeric data is selected, Microsoft Excel follows rules 4 and 5.

**Bad Data Sample**
In the following example, notice how the blank cells in the data series create blanks spaces in the chart. Also, the lack of row labels makes it difficult for readers to understand the chart, because no specific labels appear on the legend to guide them.

<table>
<thead>
<tr>
<th>clerk 1</th>
<th>clerk 2</th>
<th>clerk 3</th>
<th>clerk 4</th>
</tr>
</thead>
<tbody>
<tr>
<td>234</td>
<td>123</td>
<td>667</td>
<td>23</td>
</tr>
<tr>
<td>345</td>
<td>975</td>
<td>96</td>
<td>456</td>
</tr>
<tr>
<td>456</td>
<td>462</td>
<td>543</td>
<td>85</td>
</tr>
<tr>
<td>667</td>
<td>23</td>
<td>876</td>
<td></td>
</tr>
</tbody>
</table>

**Good Data Sample**
In the following example, notice that no blank spaces exist in the data series, so no empty spaces exist in the chart. Also, the added row labels have made the legend much easier to understand.

<table>
<thead>
<tr>
<th></th>
<th>Clerk 1</th>
<th>Clerk 2</th>
<th>Clerk 3</th>
<th>Clerk 4</th>
</tr>
</thead>
<tbody>
<tr>
<td>Item 1</td>
<td>323</td>
<td>216</td>
<td>65</td>
<td>341</td>
</tr>
<tr>
<td>Item 2</td>
<td>135</td>
<td>321</td>
<td>564</td>
<td>12</td>
</tr>
<tr>
<td>Item 3</td>
<td>321</td>
<td>197</td>
<td>301</td>
<td>761</td>
</tr>
<tr>
<td>Item 4</td>
<td>401</td>
<td>285</td>
<td>34</td>
<td>857</td>
</tr>
</tbody>
</table>
Chart Elements

A chart contains several elements, which are illustrated in the following graphic:

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title</td>
<td>Identifies the chart, and frequently includes a date or time period.</td>
<td>Average Monthly Temperatures</td>
</tr>
<tr>
<td>Category (X)</td>
<td>Identifies the data being charted on the horizontal x-axis; values in this section will be used as labels along the x-axis.</td>
<td>Cities Minneapolis, Albuquerque, Tampa</td>
</tr>
<tr>
<td>Value (Y) Axis</td>
<td>Identifies the data being charted on the vertical y-axis; values in this section will determine average temperatures</td>
<td></td>
</tr>
<tr>
<td>Element</td>
<td>Description</td>
<td>Example</td>
</tr>
<tr>
<td>-----------------</td>
<td>------------------------------------------------------------------------------</td>
<td>---------</td>
</tr>
<tr>
<td>Value Axis Title</td>
<td>Identifies the title of the value (y) axis.</td>
<td></td>
</tr>
<tr>
<td>Legend</td>
<td>Identifies the information being charted. This is especially important when you have more than one type of information charted. Using the example of the above chart, the legend identifies which information relates to each month.</td>
<td></td>
</tr>
<tr>
<td>Ticks</td>
<td>Ticks, indicating measurement increments, appear on both the y-axis and x-axis and can help improve the readability of a chart. Both y-axis and x-axis ticks are optional.</td>
<td></td>
</tr>
<tr>
<td>Origin</td>
<td>The origin is the point where the x-axis and y-axis meet. The origin is generally at zero (0) but can be modified.</td>
<td></td>
</tr>
</tbody>
</table>

**Guidelines for Charting**

The ability to create effective charts is an important skill for both oral presentations and printed text. Understanding effective charting methods allows you to present the charted information in a visually appealing way.

**Chart Summary**

Microsoft Excel 2016 offers several types of charts, each with its own unique function. Be sure to choose the type of chart that best serves your purposes. The following table provides a short summary of all the chart types available to you, as well as their functions:

<table>
<thead>
<tr>
<th>Type</th>
<th>Image</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Column</td>
<td><img src="image" alt="Column Chart" /></td>
<td>Data that is arranged in columns or rows on a worksheet can be plotted in a column chart. This chart typically displays categories along the horizontal (category) axis and values along the vertical (value) axis.</td>
</tr>
<tr>
<td>Line</td>
<td><img src="image" alt="Line Chart" /></td>
<td>Line charts can show continuous data over time on an evenly scaled axis, they are ideal for showing trends in</td>
</tr>
<tr>
<td>Type</td>
<td>Image</td>
<td>Description</td>
</tr>
<tr>
<td>----------</td>
<td>-------</td>
<td>-------------</td>
</tr>
<tr>
<td>data at equal intervals, like months, quarters, or fiscal years.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Pie</td>
<td><img src="image" alt="Pie Chart" /></td>
<td>Proportionally compares the items in one data series.</td>
</tr>
<tr>
<td>Bar</td>
<td><img src="image" alt="Bar Chart" /></td>
<td>Shows data changes between many data series.</td>
</tr>
<tr>
<td>Area</td>
<td><img src="image" alt="Area Chart" /></td>
<td>Displays the highest value or total value of items in a data series over time.</td>
</tr>
<tr>
<td>X Y (Scatter)</td>
<td><img src="image" alt="X Y Scatter Chart" /></td>
<td>Displays the relationship of several data series on a coordinate plane, marked by points.</td>
</tr>
<tr>
<td>Stock</td>
<td><img src="image" alt="Stock Chart" /></td>
<td>Illustrates fluctuation or stability in certain data series, not necessarily only for stock prices.</td>
</tr>
<tr>
<td>Surface</td>
<td><img src="image" alt="Surface Chart" /></td>
<td>Displays combinations of two sets of data, each with a common data series, in a three-dimensional coordinate plane.</td>
</tr>
<tr>
<td>Radar</td>
<td><img src="image" alt="Radar Chart" /></td>
<td>Compares multiple values of multiple data series.</td>
</tr>
<tr>
<td>Combo</td>
<td><img src="image" alt="Combo Chart" /></td>
<td>When the numbers in a chart you created vary widely from data series to data series, or when you have mixed types of data (for example, price and volume), you can plot one or more data series on a secondary vertical (value) axis.</td>
</tr>
<tr>
<td>Treemap</td>
<td><img src="image" alt="Treemap Chart" /></td>
<td>The treemap chart provides a hierarchical view of your data and an easy way to compare different levels of categorization. The treemap chart displays categories by color and proximity and can easily show lots of data which would be difficult with other chart types. The treemap chart can be plotted when empty (blank) cells exist within the hierarchal structure and treemap charts are good for comparing proportions within the hierarchy.</td>
</tr>
<tr>
<td>Type</td>
<td>Image</td>
<td>Description</td>
</tr>
<tr>
<td>--------------</td>
<td>---------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Sunburst</td>
<td><img src="image1" alt="Sunburst" /></td>
<td>The sunburst chart is ideal for displaying hierarchical data and can be plotted when empty (blank) cells exist within the hierarchal structure. Each level of the hierarchy is represented by one ring or circle with the innermost circle as the top of the hierarchy. A sunburst chart without any hierarchical data (one level of categories), looks similar to a doughnut chart. However, a sunburst chart with multiple levels of categories shows how the outer rings relate to the inner rings. The sunburst chart is most effective at showing how one ring is broken into its contributing pieces.</td>
</tr>
<tr>
<td>Histograms</td>
<td><img src="image2" alt="Histogram" /></td>
<td>Data plotted in a histogram chart shows the frequencies within a distribution. Each column of the chart is called a bin, which can be changed to further analyze your data.</td>
</tr>
<tr>
<td>Box and Whisker</td>
<td><img src="image3" alt="Box and Whisker" /></td>
<td>A box and whisker chart shows distribution of data into quartiles, highlighting the mean and outliers. The boxes may have lines extending vertically called “whiskers”. These lines indicate variability outside the upper and lower quartiles, and any point outside those lines or whiskers is considered an outlier. Use this chart type when there are multiple data sets which relate to each other in some way.</td>
</tr>
<tr>
<td>Waterfall</td>
<td><img src="image4" alt="Waterfall" /></td>
<td>A waterfall chart shows a running total of your financial data as values are added or subtracted. It is useful for understanding how an initial value is affected by a series of positive and negative values. The columns are color coded so you can quickly tell positive from negative numbers.</td>
</tr>
<tr>
<td>Funnel</td>
<td><img src="image5" alt="Funnel" /></td>
<td>Funnel charts show values across multiple stages in a process.</td>
</tr>
</tbody>
</table>

**General Hints**

Consider the following when charting:
Choose the correct chart: The different chart types are designed to communicate information in different ways. Be sure to choose the correct chart format for your information.

Chart necessary information: Consider the purpose of your chart when deciding what information to put into it. If you want to chart several data series, create multiple charts. This will allow you to focus on specific data series per chart, which will increase each chart's readability.

Maintain consistency: When creating multiple charts, be sure that they are similar in style and formatting. Informational content, not their stylistic differences, should be the focus when you have multiple charts.

Add emphasis: To indicate significance in certain chart items, you may use one of many different formatting options.

Maintain simplicity: Simple charts are easy to read. Since clarifying and communicating information is the goal of charting, complicated or busy charts are not advised.

Edit the plot area: When creating your chart, you may find excess space in the plot area.

Use labels: Labels help your audience understand chart information. You may add chart titles, axis titles, legends, data labels, data tables, or gridlines to increase its readability.

Pie Charts: Pie charts are unique from other charts. Pie charts display one data series (unlike other charts that display at least two data series). Therefore, pie charts do not have axes, plot areas, or points. Instead, they display one data series, divide it into pieces, and compare the pieces to each other.

Limit the number of slices: Keep the number of slices to a minimum by combining smaller categories into one. Too many slices will decrease your chart's readability.

Use labels for slices: Try to place labels within slices whenever possible; this helps create cleaner and more readable charts.

Compare Multiple Pie Charts: If you need to compare multiple pie charts to each other, you can consolidate them into one chart by creating a doughnut chart. These charts, like pie charts, compare the items in one data series, but can do so with more than one data series.

Focus attention: If necessary, draw your audience's attention to the particular slices you are discussing by exploding it to make it appear separate from the pie or by selecting an attractive colour, pattern, shadow, or 3-D effect.
Worksheet Design

You have two basic options for setting up your worksheet. You can choose to design your worksheet so the information to be charted is close together, or, if you have arranged your worksheet in a different way and want to chart only certain parts of your data, you can create a summary section for charting. The best option for you will depend on what the worksheet is designed to do.

Your chart will require the least amount of manual adjustments if the information to be charted is contained in a contiguous group of cells. The more information contained in contiguous cells for charting, the less work you will have to do when creating your chart.

![Excel Worksheet](image)

The above graphic is a sample worksheet section used to create the chart below. While the user needs to place the chart within the worksheet and initiate its creation, the organization of the data allows Microsoft Excel to create and format the chart automatically.

![Chart Example](image)

- Select the data series represented by the same colour in the chart.
- Press the **Delete** key and the selected series will be removed from the chart.
- The chart data remains on the worksheet.
Create a Basic Chart

Microsoft Excel 2016 makes creating charts simple. With a few clicks, Microsoft Excel will create a basic chart which you can edit and enhance to meet your needs.

- Create the data to be charted.
- Select the data to be charted.
- To select data from different areas of your worksheet or to select non-contiguous cells, hold down the Ctrl key and select the cells.
- On the Ribbon, click the Insert tab, and in the Charts group, click the Recommended Charts option.
- The Insert Chart dialog appears:

![Insert Chart dialog]

- Click the specific chart.
- Click on Ok.
- The chart appears on the same worksheet.
- The Chart Tools ➪ Design and Format command tabs appear on the Ribbon.
If the information is represented on the incorrect axes, on the **Design** tab, from the **Data** group, click the **Switch Row/Column** button.

**Modify a Chart**

If the chart you selected is not appropriate for the information you are charting, you can change it by using the Change Chart Type option.

- On the **Ribbon**, click on the **Design** tab and in the **Type** group, click on **Change Chart Type**.
- The **Change Chart Type** dialog appears:

![Change Chart Type dialog](image)

- Click on **All Charts** and select a different chart type. You can also select to use a **Combo** which is a combination of charts.
- Click on **Ok**.
- The chart is changed.
Data Series and Data Ranges

A data series identifies the information charted. For example, a data series may contain the enrolment, by school, for the current academic year. Another data series may contain the forecasted enrolment for the next academic year. If you need to delete or change the references to the cells containing the information, you will need to edit the data series.

A data range is a range of cells that contain data in a data series. To type a range, type the range's initial cell's ID, a colon, and the range's final cell's ID. The data range B2:B5 references the cells B2, B3, B4, and B5. You can add a data series to an existing chart with the Edit Data Source dialog.

- Right click the chart and from the popup menu click the Select Data option.
- On the Design tab, in the Data group, click the Select Data option.
- The Select Data Source dialog appears.
- You may add a data series only in the x-axis of your chart. To switch axes, click the Switch Row/Column button.

- Click the Add button. The Select Data Source dialog closes and the Edit Series dialog appears:

![Select Data Source dialog]

- Click the Add button. The Select Data Source dialog closes and the Edit Series dialog appears:
In the Series name box, type the name of the series. In a line chart of students' grades, a series name would be the student's name.

In the Series values box, type the appropriate data range to be added. In a line chart of student grades, the data range values would be the cells containing a specific student's grades specified in the chart.

To select a data range, click the collapse dialog arrow and select the cells to be added.

Click the Restore Dialog arrow.

Click on Ok. The Edit Series dialog closes and the Select Data Source dialog appears. Click on Ok.

The data series is added to the chart.

Deleting Data Series

Deleting a data series in a chart does not delete the data from the worksheet.

Right click the column, bar, line, or pie segment representing the data series to be deleted and from the popup menu click the Delete option.

The data series is deleted.

Format a Chart

The options in the Format dialog change depending on what chart item you select to customize. It is important to understand what chart items can and cannot be customized.

The following chart items can be filled with colours, patterns, or pictures, as well as adding and/or formatting borders and lines, shadows, and 3-D effects:

- The Chart Area (the charting space that the plot area and all label boxes rest on).
- The Plot Area (the area that the graph image appears on).
- All label boxes (chart titles, axis titles, legends, data labels, and data tables).
- Data series in an Area chart.
Data series in a Surface chart.

The following graphical items cannot be filled with colours, patterns, or pictures, but can add and/or format their borders and connection lines, shadows, or 3-D effects:
- Columns and bars
- Lines
- Pie and doughnut slices
- Bubbles
- Radar lines

If you are formatting any chart items from the Analysis group (in the Layout command tab), note that the following options are available for each function:
- Trend lines can only format their lines and add shadows.
- Lines and Error Bars can only format their lines.
- Up/Down Bars can add and/or format colours, patterns, and pictures, borders and lines, shadows, and 3-D effects.

### The Format Dialog

The Format dialog is the primary tool you will use to format your charts. The options in this dialog change depending on what chart item you choose to customize. To access the Format dialog:

- Right click the chart item you want to customize and from the popup menu select the **Format Chart Area** (chart item) option.
- The **Format Chart Area** dialog appears on the right-hand side of the screen.

Click on **Fill** to see a list of all the **Fill** options.
Click on **Border** to see a list of all the **Border** options.
The following buttons are displayed to the right-hand side of the selected chart.
Use these buttons to add **Chart Elements**, select a different **Chart Style** and use the **Filter Chart** option.

### Apply Chart Layout

Microsoft Excel provides several preformatted chart layouts to help you create your chart. Chart layouts can change the positioning of chart items, such as the title, legend, axes.

- Select your chart by clicking on the chart.
- On the **Design** tab, in the **Chart Layouts** group, click the drop down arrow of **Quick Layout**. A list of layouts will appear.
- Click the layout you prefer. The layout is applied to the selected chart.

### Applying Chart Styles

Microsoft Excel provides several preformatted chart styles to help you style your chart. Chart styles are pre-formatted colours, backgrounds, shading, gradients, and other formatting elements that can give your charts a consistent aesthetic appeal.

- Select your chart by clicking on the chart.
- On the **Design** tab, in the **Chart Styles** group, click the drop down arrow of **More**. A list of styles appears.
- Click the style you prefer. The style is applied to the selected chart.

### Fill Areas with Colours, Patterns, and Pictures

There are many chart items that can be filled with a colour, picture, or texture. These items are normally in areas where information is placed.
Add Borders and Formatting Lines

If the chart item you want to customize rests in a box or is a box, you can add and format a border. If the item is a line, you can format the line. If the item is a series of points, you can add and format its connection line.

Since the steps to format borders, connection lines, and lines are similar, Microsoft Excel uses the term line to categorize each term. The following steps will also refer to these chart items as lines.

- On your chart, right click the chart item you want to format and from the popup menu select the Format (Chart Item) option.
- The Format option appears on the right-hand side of the screen.

![Format Plot Area](image)

- Click on Border to display the Border options.
- To delete any line formatting, select the No line option.
- For a single line, select Solid line.
- For a line with a colour blend, select Gradient Line.
- To choose a gradient colour scheme, click the Pre-set gradients option and select a colour.
- To choose a style of gradient flow, click Type and select the style you prefer.
- To choose a different gradient starting point, click Direction and select the direction you prefer.
To change the width of the line, in the **Width** text box, type the width you prefer or use the nudge buttons to select the desired width.

To add multiple lines to your line, click **Compound Type** and select the style you prefer.

To add dashes to your line, click **Dash Type** and select the style you prefer.

To change the appearance of line caps (corners at the end of a line), from the **Cap type** pull down-list, select the style you prefer.

To change the appearance of line joints, from the **Join type** pull-down list, select the style you prefer.

---

**Create an Exploding Pie or Doughnut Slice**

In pie and doughnut charts, slices can be pulled out from their original positions to draw attention to them. This is effective when indicating significance to one or more slices.

With doughnut charts, you may only explode the outermost ring. If you have already created your chart, you can change the chart type to a pie or doughnut chart that has pre-exploded slices. If your chart is an unexploded pie or doughnut chart, you may customize the exploded pieces by following these steps:

- Select the pie chart by clicking on the chart.
- On the pie chart, click and hold the slice you want to explode. The cursor changes to become a four-headed arrow. Drag the slice away from the chart.
- Release the mouse button. The slice is exploded.

---

**Sparklines**

In Microsoft Excel 2016 Sparklines is available. A sparkline is a little chart displayed in a cell representing your selected data set that allows you to quickly and easily spot trends at a glance.
Create a new blank workbook.

Enter the following information on the worksheet.

<table>
<thead>
<tr>
<th></th>
<th>31-Jan-08</th>
<th>31-Jan-09</th>
<th>31-Jan-10</th>
<th>31-Jan-11</th>
</tr>
</thead>
<tbody>
<tr>
<td>Item 1</td>
<td>R 22.50</td>
<td>R 21.50</td>
<td>R 32.80</td>
<td>R 51.25</td>
</tr>
<tr>
<td>Item 2</td>
<td>R 16.95</td>
<td>R 22.10</td>
<td>R 24.24</td>
<td>R 26.32</td>
</tr>
<tr>
<td>Item 3</td>
<td>R 112.75</td>
<td>R 107.16</td>
<td>R 114.98</td>
<td>R 95.00</td>
</tr>
</tbody>
</table>

Select the cell or cells where you want to display Sparklines.

Click on the Insert tab, and then select the type of Sparkline you would like to add to your spreadsheet.

There are three types of Sparklines: Line, Column and Win/Loss.

The Create Sparklines dialog appears and prompts you to enter a Data Range you are using to create the Sparklines. The range where the Sparklines will appear is already filled in.

Enter the data range manually, or click with your mouse across to select the date range.

Click on Ok.

The Sparklines will appear in the desired cells.

Customize Sparklines

Select one or more of the Sparklines to display the Sparkline Tools Design tab. You can display certain value points like high and low points, negative points, and first and last points by selecting the corresponding options from the Show group.

You can also mark all value points by selecting Markers.
Select the desired Sparklines and click on of the styles from the Style group on the Design tab.

Exercise 12: Charts

- Open the workbook Magazines.xls from the training directory.
- Select the range A5:E10.
- Use the Chart Wizard and create a clustered column chart with a 3-D visual effect.
- Display the data series in rows.
- Enter Magazines Sold 2003 as the Chart Title.
- Place the Legend at the bottom of the chart screen.
- Location of Chart: As a new sheet.
- Remove the legend.
- Change the chart type to a 3-D Line, Line with a 3-D visual effect.
- Select the worksheet Magazines.
- Select the non-consecutive range A5:A10 and range F5:F10.
- Use the Chart Wizard and create a Pie Chart with a 3-D visual effect.
- Do not display the Legend.
- Save and close the workbook.
Microsoft Excel 2016 Basic

Preview & Print Documents

Objectives

After completion of this lesson, you will be able to –

- Preview Worksheets
- Understand Backstage View
- Change Page Set-up options
- Change the margins
- Use standard headers and footers
- Print column or row titles on every page
Preview and Print Worksheets

There are many methods of communication available for sharing data. The most practical is a printout of the spreadsheet. Since Microsoft Excel is a Windows program, you can take advantage of the graphical environment, and view your document exactly as it will print.

Headers and Footers, which appear along the top or bottom edges of each printed page, can contain valuable information. Include the time and date of the document's preparation, a descriptive title, and page numbers for large documents.

The placement of your spreadsheet data on the page can add to the impact. Centre, magnify, or reduce the actual print size of the report. A small spreadsheet can be enlarged to lend more impact. A larger spreadsheet can be scaled to fit on fewer pages.

Backstage View

Backstage View is displayed by clicking on the File option. The backstage view in each application uses a different colour scheme to differentiate it from the others.

- Backstage View houses commands that affect the document as a whole, or the application itself.
Saving, opening and closing a document, as well as creating a new one.
- Printing
- Changing Microsoft Excel options
- To return to the document, you can either click the Back button or press Escape.

**Printing Tips**

- To verify how the printout will look, use Print Preview.
- For wide worksheets, you may want to print the information in landscape orientation rather than portrait orientation.
- The Page Setup dialog allows you to modify various document properties, such as footers and headers, page alignment, and more.
- If you click the Quick Print option on the Quick Access toolbar, your document prints without allowing you to customize settings in the Print dialog.
- Quick Print may not be visible on your Quick Access toolbar.

**Default Printer**

If you want to use the same printer for all your documents, you can set a default printer.

- In the bottom left corner of your Windows screen, click the Start button and select Printers and Faxes.
- The Printers and Faxes dialog appears.
- Right click the printer you want as your default printer and select Set as Default Printer.
- A checkmark appears next to the new default printer. Click the Close button.

**Print Active Worksheets**

Microsoft Excel allows you to print the active sheet(s) in your workbook without having to print the rest of the workbook. Unless you select multiple worksheets, the active worksheet is the visible.

- To activate the worksheet, you want printed, click the tab of that worksheet. The worksheet is active.
- To make more than one worksheet active, click the tab of the first sheet you want to activate. The worksheet is active. To activate sheets adjacent to the first one you selected, press the Shift key while you click the tab of the last sheet you want to select.
- All sheets between the first and last tabs selected are active.
- To activate sheets that are not adjacent to the first one you selected, press the Ctrl key while you click the tabs of all sheets you want selected. All selected sheets are active.
- In the top left corner of the Microsoft Excel window, click on the File option.
- Click on Print.
- The Print options appear in Backstage View.
- Under Settings select to print option to print the selection, the active sheet or sheets, or the entire workbook.

![Print Options](image)

- Click the Print button.
Define Print Area

By default, Microsoft Excel prints all data on the current worksheet.

Defining the Print Area: Dialog Option

- Select the Page Layout tab.
- In the Page Setup group, click the Page Setup dialog launcher. The Page Setup dialog appears.
- Select the Sheet tab and in the Print Area text box, type the range of cells you want to print.

To select the area, click the Collapse Dialog arrow, select the desired range of cells and click the Restore Dialog arrow. Click on Ok.
- The print area is defined.

Defining the Print Area: Print Area Option

Microsoft Excel will keep the print area you have defined until it is cleared or replaced.

- To set the print area, select the range of cells you want to print.
Select the Page Layout tab and in the Page Setup group, click the drop down arrow of the Print Area button.

Select Set Print Area. The print area is set.

To add more data to the print area, select a range of cells.

In the Page Setup group, click the drop down arrow of the Print Area button and then select Add to Print Area. The selected cells are added to any previously selected data.

In the Page Setup group, click the drop down arrow of the Print Area button and select Clear Print Area to clear the print area. Any print area settings are cleared.

Print Options

Page breaks determine the boundaries of printable information. The dotted lines that appear represent the margins of the printer paper. When a document is printed, information on each side of the break will appear on different pages.

Microsoft Excel will print every page designated by a custom page break, including blank pages. Do not create more custom page breaks than you require.

To establish a custom page break, select the cell whose upper left corner is where you want the page break to appear. If you want the page break to appear between columns L and M, and between rows 8 and 9, select the cell M9.

On the Page Layout tab, in the Page Setup group, click the drop down arrow of the Breaks button and select Insert Page Break. The page break appears in the worksheet.

To remove a custom page break, select the cell whose upper left corner is where the page break you want to delete is located. If the page break appears between columns L and M, and between rows 8 and 9, select the cell M9.

On the Page Layout tab, in the Page Setup group, click the drop down arrow of the Breaks button and select Remove Page Break. The page break is removed.

Additional Print Options

The Page Setup dialog offers additional printing options. You may choose to print in colour or print gridlines and headings. If you are printing drafts and want to save ink, print low-quality drafts. You may also edit how you want cell errors to appear in printouts.

These options are all available in the Page Setup dialog.
On the Page Layout tab, in the Page Setup group, click the Page Setup dialog launcher.

The Page Setup dialog appears.

Select the Sheet tab.

To print gridlines, in the Print section, select Gridlines.

To print your worksheet in shades of black and white, in the Print section, select Black and white.

To print low-quality draft, in the Print section, select Draft quality. Deselect Draft quality when you no longer want to print in this format.

To print row and column headings, in the Print section, select Row and column headings.

To customize how cell errors will appear when printed, in the Print section, from the Cell errors as pull-down list, select the desired option. Click on Ok. The changes are saved and the Page Setup dialog closes.

**Page Setup Dialog**

In addition to the Print dialog, the Page Setup dialog provides many options to help you print your Microsoft Excel worksheets.

On the Page Layout tab, in the Page Setup group, click the Page Setup Dialog Launcher button.
The **Page Setup** dialog appears.

![Page Setup dialog](image)

- The **Page Setup** dialog consists of four tabs: **Page**, **Margins**, **Header/Footer**, and **Sheet**. Each tab allows you to customize elements of your Microsoft Excel worksheet.
- The following buttons are found on all tabs: **Print** button opens the **Print** dialog, **Print Preview** button opens **Print Preview**, the **Options** button opens the printer name on the **Print Properties** dialog.
- Click on the **Ok** button or click the **Cancel** button.

**Page Setup Dialog Tabs: Page**

The Page tab offers several options to help you specify how your worksheet(s) will print.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Orientation</td>
<td>Determines if your document prints as a portrait or as a landscape.</td>
</tr>
<tr>
<td>Scaling</td>
<td><em>Adjust to</em> allow you to customize page scale by percentage.</td>
</tr>
</tbody>
</table>
Fit to allow you to specify how many pages it takes to print your worksheet. Print Preview allows you to see the effects of scaling before you print.

<table>
<thead>
<tr>
<th>Paper size</th>
<th>Determines what size paper you will print on</th>
</tr>
</thead>
<tbody>
<tr>
<td>Print quality</td>
<td>Determines resolution</td>
</tr>
<tr>
<td>First page number</td>
<td>Indicates what number appears on the first printed page. If you want the first page number to be 1, leave the selection as Auto.</td>
</tr>
</tbody>
</table>

**Page Setup Dialog Tabs: Margins**

The **Margins** tab allows you to set your margins and centre your data vertically, horizontally, or both. All margin values are measured in centimetres.

**Page Setup Dialog Tabs: Header/Footer**

Headers and footers are the text printed at the top and bottom of pages, such as the date, page number, the filename, or other text. The **Header/Footer** tab provides options to customize page headers or footers.
### Option Description

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Header</td>
<td>Provides several pre-written headers.</td>
</tr>
<tr>
<td>Footer</td>
<td>Provides several pre-written footers.</td>
</tr>
<tr>
<td>Custom Header</td>
<td>Allows you to create your own header using the <em>Header</em> dialog box.</td>
</tr>
<tr>
<td>Custom Footer</td>
<td>Allows you create your own footer using the <em>Footer</em> dialog box.</td>
</tr>
<tr>
<td>Different odd and even pages</td>
<td>Allows you to create different headers or footers for odd and even pages.</td>
</tr>
<tr>
<td>Different first page</td>
<td>Allows you to create a different header or footer for only the first page.</td>
</tr>
<tr>
<td>Scale with document</td>
<td>Adjusts the header and footer font and scaling to match the rest of the document.</td>
</tr>
<tr>
<td>Align with page margins</td>
<td>Sets headers and footers within the page margins.</td>
</tr>
</tbody>
</table>

### Page Setup Dialog Tabs: Sheet

The *Sheet* tab gives you several options for determining which elements of your workbook are printed.
Option | Description
--- | ---
Print area | Specifies a range of cells to print.
Print titles | Specifies the rows or columns to print on each page. These rows or columns are likely to be the headings that define what the rest of the row or column's information is used for.
Print | Allows you to print only certain elements of your worksheet.
Page order | Sets the order in which worksheet pages are numbered and printed

**Customize Page Layout**

In order to fit information on a page or change the appearance of a page, you may want to customize your page layout. Several different aspects of your page layout may be altered to customize the way your printed worksheet appears, including:

**Change the Orientation**

Most documents are portrait (tall) oriented, but many worksheets may be easier to read with a landscape (wide) orientation. In addition, changing the orientation can also help you fit a large worksheet onto one sheet of paper.
On the Ribbon, select the Page Layout tab and in the Page Setup group, click the drop down arrow of the Orientation button to select the desired orientation.

Change the Paper Size

The default paper size is 8 1/2” x 11”, but you must select A4.

To select A4 paper size:
- On the Ribbon, select the Page Layout tab and in the Page Setup group, click the drop down arrow of the Size button and select the desired paper size.
Adjust the Scale

The scaling option allows you to adjust the size of the printed copy. The default size of the printed copy is **100%**. You can adjust the scale to a percentage of the default size, or choose to fit the worksheet to a specific number of pages; both allow you to reduce or enlarge the entire worksheet.

- On the **Ribbon**, select the **Page Layout** tab and from the **Scale to Fit** group, in the **Scale** text box, type the appropriate percentage.

Microsoft Excel allows you to set a maximum number of pages for your worksheet to fit within. You may choose to re-scale your worksheet either horizontally, vertically, or both in order to make it fit within this set number of pages.

- On the **Ribbon**, select the **Page Layout** tab.
- To rescale your worksheet horizontally within a page limit, in the **Scale to Fit** group, in the **Width** text box, type or select the appropriate number of pages.
- To rescale your worksheet vertically within a page limit, in the **Scale to Fit** group, in the **Height** text box, type or select the appropriate number of pages.

Adjust the Margins

- On the **Ribbon**, select the **Page Layout** tab and in the **Page Setup** group, click the drop down arrow of the **Margins** button.
- The **Margins** pull-down list appears.
  - From the **Margins** pull-down list, select the desired option.
  - From the **Margins** pull-down list, select **Custom Margins**. The **Page Setup** dialog appears, with the **Margins** tab selected.
  - In the **Top**, **Bottom**, **Left**, or **Right** text boxes, type the appropriate margins.
- Click on **Ok**.

Adjust the Header and Footer Margins

- On the **Ribbon**, select the **Page Layout** tab and in the **Page Setup** group, click the drop down arrow of the **Margins** button and select **Custom Margins**.
- The **Page Setup** dialog appears, with the **Margins** tab selected.
- In the **Header and Footer** text boxes, type the appropriate margins.
- Click on **Ok**.
Centre the Worksheet on the Page

- On the Ribbon, select the Page Layout tab and in the Page Setup group, click the drop down arrow of the Margins button and select Custom Margins.
- The Page Setup dialog appears, with the Margins tab selected.
- To centre within the left and right margins, in the Centre on page section, select Horizontally.
- To centre within the top and bottom margins, in the Centre on page section, select Vertically.
- Click on Ok.

Modify Headers and Footers

Headers and footers can be extremely useful tools for organizing and identifying a document. After you have created a header or footer, Microsoft Excel allows you to customize the header and footer information for a given worksheet.

Set a Custom Page Number

By default, page numbering starts with one. Microsoft Excel allows you to begin numbering the first page with a number other than one.

- Add your header or footer.
- On the Ribbon, select the Page Layout tab and in the Page Setup group, click the Page Setup Dialog Launcher button.
- The Page Setup dialog appears.
- Select the Page tab. The Page Setup dialog refreshes to display the Page options.
In the First page number text box, type the number that will begin the page numbering. Click the Ok button.

The Page Setup dialog closes.

Add Headers and Footers

Headers and footers can be useful tools for organizing and identifying a document. A header is a section of information that is printed above the body of the document, and a footer is a section of information that is printed below the body of the document.

You may choose to add a pre-set header or footer to your document, or to create a custom header and footer.

Use Pre-set Headers and Footers

Pre-set headers and footers are provided by Microsoft, or can be taken from documents you have used in the past.

On the Ribbon, select the Page Layout tab and in the Page Setup group, click the Page Setup dialog launcher button.

The Page Setup dialog appears.

Select the Header/Footer tab. The Page Setup dialog refreshes to display the Header/Footer options.
From the **Header or Footer** pull-down list, select a pre-set header or footer. Click the **Ok** button.

The header or footer is applied to the document. The header or footer may display the header or footer code on your screen, but the text will be visible when the worksheet is printed.

**Create Custom Headers and Footers**

You may want to create your own headers or footers. You can adjust the font face and the size, add your own text, and add text that will be automatically updated with your document.

- On the **Ribbon**, select the **Insert** tab and in the **Text** group, click the **Header & Footer** button.
- A header appears, divided into three sections, and the **Design** tab is visible on the **Ribbon**.
- One section of the header appears on the left of the top margin, one in the centre, and one on the right. Although all three sections may not be visible, clicking in one of these areas will cause that section to appear.

To work with a footer, in the **Navigation** section, click the **Go to Footer** button. The footer, like the header, is divided into three sections. Although all three may not be visible, clicking in one of these areas will cause that section to appear.

- Click the section of the header or footer where you want to add content.
- Type or use the **Header & Footer Elements** to add all desired information.
- To change the formatting of your text, select the text that you want to format.
On the Ribbon, select the Home tab and then use the commands in the Font group, make all desired formatting changes.

To stop working with your header or footer, click outside the header or foot.

Add a Custom Header or Footer: Dialog Box Option

On the Ribbon, select the Page Layout tab and in the Page Setup group, click the Page Setup dialog launcher button.

The Page Setup dialog appears.

Select the Header/Footer tab and click on the Custom Header or Custom Footer button.

The Header or Footer dialog appears, respectively.

In the Left section, Centre section, and Right section text boxes, type or use the Header & Footer Elements to insert the desired information in each section of your header or footer.

Click on Ok.

Header and Footer Elements

Microsoft Excel allows you to create custom headers and footers by either typing your own text or adding specific text fields. The buttons available in the Header & Footer elements group provide you with text fields that will automatically update the information displayed as your document changes. These elements can also be added to pre-set headers and footers to customize your document.
The Code column in the table below shows the command that Microsoft Excel will insert when the option is selected. Although you may see only the code when looking at your document, the code will be translated to the corresponding information when the sheet is printed.

<table>
<thead>
<tr>
<th>Button</th>
<th>Code</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>&amp;[Page]</td>
<td></td>
<td>Inserts the page number. Excel will count only the pages that have data in at least one cell.</td>
</tr>
<tr>
<td>&amp;[Pages]</td>
<td></td>
<td>Inserts the total number of pages. Excel will count only the pages that have data in at least one cell.</td>
</tr>
<tr>
<td>&amp;[Date]</td>
<td></td>
<td>Inserts the current date</td>
</tr>
<tr>
<td>&amp;[Time]</td>
<td></td>
<td>Inserts the current time</td>
</tr>
<tr>
<td>&amp;[File]</td>
<td></td>
<td>Inserts the filename of the workbook</td>
</tr>
<tr>
<td>&amp;[Tab]</td>
<td></td>
<td>Inserts the name of the current worksheet</td>
</tr>
<tr>
<td>&amp;[Path]&amp;[File]</td>
<td></td>
<td>Inserts the path and filename</td>
</tr>
<tr>
<td>&amp;[Picture]</td>
<td></td>
<td>Displays the <em>Insert Picture</em> dialog box so you can insert a picture.</td>
</tr>
<tr>
<td>None</td>
<td></td>
<td>Displays the <em>Format Picture</em> dialog box so you can adjust picture properties.</td>
</tr>
<tr>
<td>None</td>
<td></td>
<td>Available only in the <em>Header</em> and <em>Footer</em> dialog boxes; displays the <em>Font</em> text box to adjust text formatting.</td>
</tr>
</tbody>
</table>
**Other Printing Options**

Microsoft Excel provides many options for modifying how your worksheet will appear on a printed sheet. Many features that appear on your screen, such as gridlines and row and column headings, will not automatically print. Choose to include other elements in your printed document.

**Print Gridlines**

Gridlines (outlines of each cell) will not print by default in Microsoft Excel 2016, and can be helpful in printed documents.

- On the **Ribbon**, select the **Page Layout** tab and in the **Sheet Options** group, in the **Gridlines** section, select **Print**.
- Print the document.

**Print Row and Column Headings**

When planning and troubleshooting a worksheet, you may find it helpful to print the column (A, B, C...) and row headings (1, 2, 3...). The column and row headings will not print in your worksheet unless you specify it.

- On the **Ribbon**, select the **Page Layout** tab and in the **Sheet Options** group, in the **Headings** section, select **Print**.
- Print the document.

**Repeat Items on Each Page**

When you are working with large worksheets, repeating information (like row or column descriptions) on subsequent pages can help improve the readability of your reports. You can specify which cells you would like to repeat on each page as print titles. After print titles have been defined, row headings will appear at the left of the page and column headings will appear at the top of the page when printing a multi-page worksheet.

- On the **Page Layout** tab, in the **Page Setup** group, click the **Print Titles** button.
- The **Page Setup** dialog appears, with the **Sheet** tab displayed.
- Under **Print titles**, in the **Rows to repeat at top** text box, type an absolute row reference for the row you want to repeat. If you want row 5 to repeat, type $5:$5.
Under **Print titles**, in the **Columns to repeat at left** text box, type an absolute column reference for the column you want to repeat. If you want column C to repeat, type $C:$C.

- The selected row and/or column will repeat on each page when printed.
- You can repeat several rows and columns on each printed page. Rows and columns that you choose to repeat must be contiguous.

### Change the Print Quality

Change the quality of a printout to print at a lower resolution for drafts or at a higher resolution for final reports. Resolution is the number of dots per linear inch (dpi) that appear on the printed page. Resolution options vary according to your printer type.

- On the **Page Layout** tab, in the **Page Setup** group, click the **Page Setup dialog launcher** button.
- The **Page Setup** dialog appears, with the **Page** tab displayed.
- From the **Print quality** pull-down list, select the resolution you want for your printout. Higher resolutions will produce higher quality printouts, but they will take longer to print and may use more ink.
- Click the **Ok** button. The print quality is changed.

### Exercise 13: Printing

- Open the workbook **Quarter.xls** from the training directory:
- Do a **Spell Check** on the document and correct any spelling mistakes.
- Change the orientation of the document to **Landscape**.
- Centre the printout horizontally and vertically on the page.
- Add the following as a header in the left section of the page: **University of Pretoria**
- Add the filename as the footer in the left section
- Add the name of the worksheet as the footer in the right section.
- **Print Preview** the document. Save and close the workbook.
Microsoft Excel 2016 Tips and Tricks

- **Text to Column.** Highlight a cell. Click on the Data tab. Click on Text to Columns. Click on Delimited data type and click on Next.

- **Find duplicate values without removing them.** Highlight a column. Click on the Home tab. Click on the Conditional Formatting drop down arrow. Select Highlight Cell Rules. Select Duplicate Values. Select the choice of colour for the highlighting.

- **Sparklines.** Best used for tracking trends. Select the cell where you would like the Sparkline to be displayed. Click on the Insert tab and from the Sparkline menu select the display. Select the range of data. When the Sparkline is inserted, the Design tab opens with options to change the design of the Sparkline.

- **View Two or More Worksheets in the same workbook at the same time.** On the View tab, in the Windows group, click the New Window button. On the View tab, in the Window group, click the View Side by Side button.

- **Hold down the Control key while tapping an arrow button will select every cell all the way to the end of the sheet.**

- **Flip through worksheets by holding the Control key while pressing either page down or page up.**

- **Turn a range of numbers into currency, complete with a dollar sign and two decimal places, by pressing control, shift, and $ at the same time.**

- **Turn a number into a date (day, month, and year) by pressing control, shift, and # simultaneously.**

- **Quick Analysis is a small menu located at the bottom right-hand corner of a table or list in Excel 2016 that pulls together the basic things that most users do with similar data sets. Instead of having to go back to the ribbon and find the feature, you just click on to the corner of the table.**

- **A new feature in Excel 2016, users can select columns on a table and have the spreadsheet make a few different projections as to how the results will play out in the future.**
# Quick Reference Guide

## File

<table>
<thead>
<tr>
<th>Command</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>New File</td>
<td>Control + N</td>
</tr>
<tr>
<td>Open File</td>
<td>Control + O</td>
</tr>
<tr>
<td>Save File</td>
<td>Control + S</td>
</tr>
<tr>
<td>Print</td>
<td>Control + P</td>
</tr>
</tbody>
</table>

## Edit

<table>
<thead>
<tr>
<th>Command</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Undo</td>
<td>Control + Z</td>
</tr>
<tr>
<td>Repeat</td>
<td>Control + Y</td>
</tr>
<tr>
<td>Cut</td>
<td>Control + X</td>
</tr>
<tr>
<td>Copy</td>
<td>Control + C</td>
</tr>
<tr>
<td>Paste</td>
<td>Control + V</td>
</tr>
<tr>
<td>Fill Down</td>
<td>Control + D</td>
</tr>
<tr>
<td>Fill Right</td>
<td>Control + R</td>
</tr>
<tr>
<td>Clear Contents</td>
<td>Delete</td>
</tr>
<tr>
<td>Find</td>
<td>Control + F</td>
</tr>
<tr>
<td>Replace</td>
<td>Control + H</td>
</tr>
<tr>
<td>Go To</td>
<td>Control + G</td>
</tr>
</tbody>
</table>

## Format

<table>
<thead>
<tr>
<th>Command</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Format Cells</td>
<td>Control + 1</td>
</tr>
<tr>
<td>Bold</td>
<td>Control + B</td>
</tr>
<tr>
<td>Italic</td>
<td>Control + I</td>
</tr>
<tr>
<td>Underline</td>
<td>Control + U</td>
</tr>
<tr>
<td>Strikeout</td>
<td>Control + 5</td>
</tr>
<tr>
<td>Apply #,##0.00 Number Format</td>
<td>Control + Shift + !</td>
</tr>
<tr>
<td>Apply R#,##0.00 Number Format</td>
<td>Control + Shift + $</td>
</tr>
<tr>
<td>Apply 0% Number Format</td>
<td>Control + Shift + %</td>
</tr>
</tbody>
</table>

## Tools

<table>
<thead>
<tr>
<th>Command</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Spelling</td>
<td>F7</td>
</tr>
<tr>
<td>Macros</td>
<td>Alt + F8</td>
</tr>
</tbody>
</table>

## Help

<table>
<thead>
<tr>
<th>Command</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Office Assistant</td>
<td>F1</td>
</tr>
<tr>
<td>What's This?</td>
<td>Shift + F1</td>
</tr>
</tbody>
</table>

## Function Shortcut Keys
Insert new worksheet = Alt + Shift + F1
Insert a chart sheet = Alt + F1
Save As = Alt + F2
Edit active cell = F2
Edit cell comment = Shift + F2
Save = Alt + Shift + F2
Paste Name = F3
Paste Function = Shift + F3
Redo/Repeat last action = F4
Repeat Find or Go To = Shift + F4
Close active window = Control + F4
Exit program = Alt + F4
Go To = F5
Find = Shift + F5
Restore window = Control + F5
Next window = F6
Previous pane or workbook = Shift + F6
Next workbook window = Control + F6
Extend cell selection = F8
Add to the selection = Shift + F8
Resize the window = Control + F8
Calculate workbook = F9
Calculate active worksheet = Shift + F9
Minimise workbook = Control + F9
Activate menus = F10
Display shortcut menu = Shift + F10
Maximise document window = Control + F10
Chart = F11
Insert a new worksheet = Shift + F11
Save As = F12
Save = Shift + F12
Open = Control + F12
Print = Control + Shift + F12

Worksheet Direction Keys - Ready Mode

One cell left = Left Arrow or Shift + Tab
One cell right = Right Arrow or Tab
One cell up = Up Arrow
One cell down = Down Arrow
Cell A1 of active worksheet = Control + Home
Previous page = Page Up
Next page = Page Down
Move to first cell in column A = Home
Move right to last active cell = End + Right Arrow
Move left to last active cell = End + Left Arrow
Move up to last active cell = End + Up Arrow
Move down to last active cell = End + Down Arrow
Cursor Control - Edit Mode

- Left one character = Left Arrow
- Right one character = Right Arrow
- Enter data and move up one cell = Up Arrow
- Enter data and go down one cell = Down Arrow or Enter
- Erase one character to the left = Backspace
- Move to the preceding word = Control + Left Arrow
- Move to the following word = Control + Right Arrow
- Move cursor to end of line = End
- Places entry into active cell = Enter
- Erases entry in Edit mode = Escape
### Glossary of Terms

**Absolute Reference**
The cell addresses or range name that always refers to the same location in a formula argument, even if the formula is copied or moved. Adding dollar signs before the formal arguments designates an absolute reference.

**Active Cell**
The cell displayed with a heavy border; it indicates the cell is selected.

**Address**
The location of a particular cell in a workbook, identified by the worksheet name, column letter, and row number.

**Auto Calculate**
A feature that allows you to check the result of a selected range of cells containing numerical information before entering an actual formula.

**AutoCorrect**
A feature that automatically corrects common spelling and formatting errors as you enter data into the worksheet.

**Chart**
A visual depiction of selected worksheet data. The ranges selected and plotted against each other are known as data series.

**Chart Objects**
The individual graphic elements of a chart.

**AutoFill**
A feature that allows you to add data using the fill handle located in the active cell border. This feature recognises date, time, text, and trend data.

**AutoFilter**
A feature that allows you to specify criteria to instantly view subsets of data contained within a database.

**AutoSum**
A feature that allows you to quickly sum rows and columns of numerical entries.

**Cell**
The intersection of a column and row. It is the smallest unit of a worksheet. You can enter and store data as text, values, functions or formula.

**Cell Address**
The headings of the column and row intersections as the cell.

**Formula Bar**
The portion of the Excel window that is used to enter or edit data or formulas in a worksheet cell. It also displays the constant value or formula contained in the active cell.

**Function**
A prefabricated Excel formula designed to return a value based on a range of cells. An example of a function is the =SUM function.
Chart Sheet
One of the three document types available in Excel.

Chart Wizard
A special feature that guides the user through the creation and annotation of the graphic objects in a chart.

Column Headers
The heading box at the top of each worksheet column.
The headers are labelled A through IV.

Conditional Formatting
A format, such as cell shading or font colour that Excel automatically applies to cells if a specified condition is true.

Footer
Information that appears along the bottom edge of a printed page of worksheet output, such as titles, names, page numbers, etc.

Formatting
The application of specific attributes to the contents of a worksheet.
These attributes control the final appearance of the worksheet.
They may include character and numerical formatting.

Formula
An equation that calculates a result and displays it in the worksheet.

Shortcut Menu
A menu that opens when you right-click an object.
Right-click a portion of the worksheet, to open the standard shortcut menu.
If you right-click a toolbar, a special toolbar shortcut menu appears.

Function Palette
A special feature that guides you through the creation and editing of complex formulas.

Headers
Information that appears along the top edge of a printed page of worksheet output, such as titles, names, page numbers, etc.

Label
The descriptive text heading in a cell that describes the row or column of values.

Menu Bar
The bar at the top of the Excel window that displays the names of the menus.

Panes
Used to display several open workbooks at one time.
Selecting the Split command from the Window menu creates panes.

Range
A rectangular group of contiguous selected cells.

Row Header
The heading box at the left of each worksheet row.

Value
A numerical entry in a worksheet cell.
<table>
<thead>
<tr>
<th>Status Bar</th>
<th>Workbook</th>
</tr>
</thead>
<tbody>
<tr>
<td>The bar along the bottom of the Excel program window that displays the current command functions, the next step, or a definition of the current activity.</td>
<td>The basic Excel document, consisting of a collection of worksheets.</td>
</tr>
</tbody>
</table>

The End